axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <d...@yahoo.com>
Subject Fwd: Re : problem with basic authentication with Websphere as client on ZOS
Date Tue, 16 Sep 2003 15:36:13 GMT
FYI - BUG.

--- arnaud.peyre@cnedi06.cnafmail.fr wrote:
> Subject: Re : problem with basic authentication with Websphere as client on ZOS
> To: axis-user@ws.apache.org
> From: arnaud.peyre@cnedi06.cnafmail.fr
> Date: Tue, 16 Sep 2003 15:55:42 +0200
> 
> 
> Hi,
> 
> I've found the solution.
> I had to to modify the HTTPSender class at line 216 :
> 
> otherHeaders.append(HTTPConstants.HEADER_AUTHORIZATION)
>                     .append(": Basic ")
>                     .append(Base64.encode(tmpBuf.toString().getBytes()))
>                     .append("\r\n");
> 
> become
> 
> otherHeaders.append(HTTPConstants.HEADER_AUTHORIZATION)
>                     .append(": Basic ")
>                     .append(Base64.encode(tmpBuf.toString
> ().getBytes(HTTPConstants.HEADER_DEFAULT_CHAR_ENCODING)))
>                     .append("\r\n");
> 
> It works fine with a ZOS or Windows client.
> 
> Souldn't it be corrected in AXIS?
> 
> Arnaud
> 
> 
> 
> 
> |---------+-------------------------------->
> |         |           arnaud.peyre@cnedi06.|
> |         |           cnafmail.fr          |
> |         |                                |
> |         |           16/09/2003 09:49     |
> |         |           Veuillez répondre à  |
> |         |           axis-user            |
> |         |                                |
> |         |           |-------------------||
> |         |           | [ ] Accusé de     ||
> |         |           |     réception     ||
> |         |           |-------------------||
> |         |           |-------------------||
> |         |           | [ ] Détailler le  ||
> |         |           |     groupe        ||
> |         |           |-------------------||
> |---------+-------------------------------->
>  
>
>-------------------------------------------------------------------------------------------------------------------------------|
>   |                                                                                 
           
>                                  |
>   |        Pour :   axis-user@ws.apache.org                                         
           
>                                  |
>   |        cc :                                                                     
           
>                                  |
>   |        Objet :  problem with basic authentication with Websphere as client on ZOS
          
>                                  |
>   |                                                                                 
           
>                                  |
>  
>
>-------------------------------------------------------------------------------------------------------------------------------|
> 
> 
> 
> 
> Hi all,
> 
> I'm actually trying client AXIS 1.1 APIs on a Websphere 3.5 (we will soon
> migrate in 5) ZOS for a RPC call.
> The target web service is located on a Tomcat 4.1 on Windows.
> 
> Client APIs work fine except that basic athentication does not work (the
> same client works fine in the Windows world).
> It seems that user and password are send in EBCDIC (the native ZOS
> encoding)
> to the Windows server. So the Windows server can't authenticate this user.
> 
> Is there a way to configure something to force ASCII for the user and
> password?
> Any help would be greatly appreciated!
> 
> Arnaud
> 
> 
> 
> 
> 
> 
> 
> 


=====
Davanum Srinivas - http://webservices.apache.org/~dims/

Mime
View raw message