axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ros...@opensource.lk
Subject error/problem while CVS commit
Date Sun, 27 Jul 2003 11:11:42 GMT
Hi,

I had two files named "echoHeaderStringHandler.h" and "echoHeaderStringHandler.cpp" in the
apache cvs repository. My requirement was to rename the above two files to "EchoHeaderStringHandler.h"
and "EchoHeaderStringHandler.cpp". (To capitalize only the first character of both files).
So what I did was the following. (I will take one file for example to explain my problem).
I use wincvs ver 1.2 and all the commands were given using the menu icons/options and I am
a committer of axis c++.

1) Used 'cvs remove' to remove the file "echoHeaderStringHandler.h" (Result: success)
2) Used 'cvs commit' to commit the change so the removal is permanent. (Result: success)
3) Used 'cvs add' to add the new file (after renaming) "EchoHeaderStringHandler.h" (Result:
success and it ask me to use 'cvs commit' to add this file permanently)
4) Now when I use 'cvs commit' to commit this new file I get the following error message.

Error message:
assertion "key != NULL" failed: file "/usr/src/gnu/usr.bin/cvs/cvs/../../../../contrib/cvs/src/hash.c",
line 312
cvs [server aborted]: received abort signal

I tried the above 4 steps several times and I get the same error message.

Your response is greatly appreciated.

Thanks,
Roshan

---------------
Lanka Software Foundation  (http://www.opensource.lk)
Promoting Open-Source Development in Sri Lanka.
--------------- 

Mime
View raw message