axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 21550] New: - AxisFault while trying to view WSDL for Version, AdminService, User-Defined service
Date Sun, 13 Jul 2003 20:58:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21550>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21550

AxisFault while trying to view WSDL for Version, AdminService, User-Defined service

           Summary: AxisFault while trying to view WSDL for Version,
                    AdminService, User-Defined service
           Product: Axis
           Version: 1.1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Blocker
          Priority: Other
         Component: Basic Architecture
        AssignedTo: axis-dev@ws.apache.org
        ReportedBy: naga@timogen.com
                CC: naga@timogen.com


I am using Axis 1.1 on Windows 2000 SP3 with j2sdk1.4.2.
SimpleAxisServer has been started.
Web page for Axis is visted.  List of services is displayed -
Version, AdminService and a user-defined service (MyService from 
samples/userguide/example3).  I click on the WSDL of each of these
three services, and get this within the WSDL -

<?xml version="1.0" encoding="UTF-8" ?> 
- <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <soapenv:Body>
- <soapenv:Fault>
  <faultcode 
xmlns:ns1="http://xml.apache.org/axis/">ns1:Server.NoService</faultcode> 
  <faultstring>The AXIS engine could not find a target service to invoke! 
targetService is null</faultstring> 
- <detail>
  <ns2:stackTrace xmlns:ns2="http://xml.apache.org/axis/">AxisFault faultCode: 
{http://xml.apache.org/axis/}Server.NoService faultSubcode: faultString: The 
AXIS engine could not find a target service to invoke! targetService is null 
faultActor: faultNode: faultDetail: The AXIS engine could not find a target 
service to invoke! targetService is null at 
org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:492) at 
org.apache.axis.transport.http.SimpleAxisWorker.run(SimpleAxisWorker.java:337) 
at org.apache.axis.transport.http.SimpleAxisServer.run
(SimpleAxisServer.java:173) at 
org.apache.axis.transport.http.SimpleAxisServer.start
(SimpleAxisServer.java:212) at 
org.apache.axis.transport.http.SimpleAxisServer.start
(SimpleAxisServer.java:220) at 
org.apache.axis.transport.http.SimpleAxisServer.main(SimpleAxisServer.java:283)
</ns2:stackTrace> 
  </detail>
  </soapenv:Fault>
  </soapenv:Body>
  </soapenv:Envelope>

Mime
View raw message