axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 20464] New: - Possible classloader conflict when Axis compile *.jws files within WAS 5.0
Date Wed, 04 Jun 2003 04:22:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20464>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20464

Possible classloader conflict when Axis compile *.jws files within WAS 5.0

           Summary: Possible classloader conflict when Axis compile *.jws
                    files within WAS 5.0
           Product: Axis
           Version: 1.1rc2
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Deployment / Registries
        AssignedTo: axis-dev@ws.apache.org
        ReportedBy: shrimpboy@sina.com


I deployed the Axis 1.1 RC2 in the WAS 5.0, when I want to execute the sample 
link: http://gb180308:9080/axis/EchoHeaders.jws?wsdl, an error code happened as 
following:
<font color=red>
AXIS error
Sorry, something seems to have gone wrong... here are the details:

Fault - Error while compiling:  C:\Program 
Files\WebSphere\AppServer\installedApps\gb180308\Apache-Axis.ear\axis.war\WEB-
INF\jwsClasses\EchoHeaders.java
AxisFault
 faultCode: {http://xml.apache.org/axis/}Server.compileError
 faultSubcode: 
 faultString: Error while compiling:  C:\Program 
Files\WebSphere\AppServer\installedApps\gb180308\Apache-Axis.ear\axis.war\WEB-
INF\jwsClasses\EchoHeaders.java
 faultActor: 
 faultNode: 
 faultDetail: 
	{}Errors: Error compiling C:\Program 
Files\WebSphere\AppServer\installedApps\gb180308\Apache-Axis.ear\axis.war\WEB-
INF\jwsClasses\EchoHeaders.java:
Line 59, column 7:  import ????? javax.servlet.http.HttpServletRequest?
Line 0, column 0: 
1 ???
</font>

I checked the log of WAS 5.0, it said that the class 
javax.servlet.http.HttpServletRequest could not be found! You know, it's 
impossible, I know this class is packaged in <was_installdir>/lib/j2ee.jar and 
is loaded in the classloader path. So I think it is maybe a problem when Axis 
interacts with WAS 5.0. Please verify, thanks!

Mime
View raw message