axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19239] - hexidecimal buffer size dumped into response XML from SOAP call
Date Tue, 22 Apr 2003 23:57:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19239>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19239

hexidecimal buffer size dumped into response XML from SOAP call





------- Additional Comments From joe_mueller@mentor.com  2003-04-22 23:57 -------
Sorry, the bug report was submitted prior to completion. The function is 
defined as:

public String testInterface(String ref) {
    return "retval: " + ref;
}

When called (and traced via TCPTrace), here's the result. Notice the 205 prior 
to the XML payload and the zero following it. These numbers are screwing up the 
parsing of the XML on the client side (Microsoft SOAP Toolkit 3.0). If I use 
the Microsoft Trace Utility, it also confirms that the returned XML is invalid 
and contains the hex numbers as indicated. This does not appear to be fatal for 
simple return types, but when returning complex types and decoding them with 
custom type mappers on the Microsoft side, the problem is fatal.


==== Request ====
POST /services/AuthcodeExpressServer HTTP/1.1
SOAPAction: ""
Content-Type: text/xml; charset="UTF-8"
User-Agent: SOAP Toolkit 3.0
Host: 127.0.0.1
Content-Length: 529
Connection: Keep-Alive
Cache-Control: no-cache
Pragma: no-cache

<?xml version="1.0" encoding="UTF-8" standalone="no"?><SOAP-ENV:Envelope 
xmlns:SOAPSDK1="http://www.w3.org/2001/XMLSchema" 
xmlns:SOAPSDK2="http://www.w3.org/2001/XMLSchema-instance" 
xmlns:SOAPSDK3="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-
ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body SOAP-
ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAPSDK4:testInte
rface 
xmlns:SOAPSDK4="http://api.authex.mentor.com"><ref>VBref</ref></SOAPSDK4:testInt
erface></SOAP-ENV:Body></SOAP-ENV:Envelope>
==== Response ====
HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Transfer-Encoding: chunked
Date: Tue, 22 Apr 2003 17:17:28 GMT
Server: Apache Coyote/1.0

205
<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <ns1:testInterfaceResponse 
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" 
xmlns:ns1="http://api.authex.mentor.com">
   <testInterfaceReturn xsi:type="xsd:string">retval: 
VBref</testInterfaceReturn>
  </ns1:testInterfaceResponse>
 </soapenv:Body>
</soapenv:Envelope>
0

Mime
View raw message