axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16948] New: - SOAPBodyElement does not associated with specified prefix
Date Mon, 10 Feb 2003 23:18:11 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16948>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16948

SOAPBodyElement does not associated with specified prefix

           Summary: SOAPBodyElement does not associated with specified
                    prefix
           Product: Axis
           Version: 1.1RC1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Basic Architecture
        AssignedTo: axis-dev@ws.apache.org
        ReportedBy: stuart.wheater@arjuna.com


If SOAPBody.addBodyElement(name) is followed by SOAPBodyElement.addChildElement
(localname, prefix), with same prefix, then the resulting SOAPElement does not 
having a prefix. For example:

Name            aName        = envelope.createName("A", "a", A_NS_URI);
SOAPBodyElement aBodyElement = body.addBodyElement(aName);
SOAPElement     bElement     = aBodyElement.addChildElement("AA", "a");

If the envelope is printed "AA" is "<AA>" not "<a:AA>".

Mime
View raw message