axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16099] New: - currentContent not set in SOAPPart object when created
Date Wed, 15 Jan 2003 09:45:51 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16099>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16099

currentContent not set in SOAPPart object when created

           Summary: currentContent not set in SOAPPart object when created
           Product: Axis
           Version: current (nightly)
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Basic Architecture
        AssignedTo: axis-dev@xml.apache.org
        ReportedBy: cnc@trifork.com


Hi

When a new SOAPPart object is created the currentContent object is not set,
unless the setContent method is called explicitly after wards. The result of
this is that null is always returned when you call the getContent method.

As I see it this can be fixed in a number of places in the SOAPPart class. The
most obvious would be in the constructor (e.g., in a method called from the
constructor) or directly in the getContent method.

I have attached a fix to this bug report which fixes the problem in the
getContent method. If you would rather have it fixed somewhere else, please do
so or mail me so I can create another fix.

You can reproduce the problem by running the jaxrpc branch of the CTS for J2EE 1.4

Cheers
Claus Nyhus Christensen
cnc@trifork.com

Mime
View raw message