axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vidyanand Murunikkara" <Vidyan...@infravio.com>
Subject RE: versions of current dependency set?
Date Mon, 02 Dec 2002 19:09:50 GMT
Hi Eric

The present vesion of commons-logging in the lib dir is 1.0.2 and that
of  commons-discovery is 0.1. For other versions of jars being used you
can refer to docs/building-axis.html.

Vidyanand.



-----Original Message-----
From: Eric.D.Friedman@WellsFargo.COM
[mailto:Eric.D.Friedman@WellsFargo.COM]
Sent: Monday, December 02, 2002 9:44 AM
To: axis-dev@xml.apache.org
Subject: versions of current dependency set?


Can someone please tell me how this project manages its dependencies?  I
need to integrate axis into an application in which other components
have
overlapping dependencies (log4j, commons-discovery, etc).  To do this, I
need to know what (minimum|optimum|maximum) versions of these libraries
axis
depends on.

Looking in the 'lib/' directory, I see only jar files with no indication
of
which version I'm looking at, with the exception of log4j, which is
1.2.4 in
the 1.0 release and a nightly build (why?) in the axis nightly builds.

commons-logging and commons-discovery are not versioned by name, and
there
doesn't seem to be any documentation that covers this point.

Unfortunately I don't have CVS access (draconian firewall), so if this
information is kept as metadata in the repository, I can't see it.

Thanks in advance for any pointers.

Eric

Mime
View raw message