axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <d...@yahoo.com>
Subject RE: Few questions on the build
Date Wed, 20 Nov 2002 19:32:48 GMT
Here's a list of jars in my xml-axis\java\lib directory. (See
http://xml.apache.org/axis/dist/1_0/dependencies.html for URL's)

activation.jar
jcert-1_0_3.jar
jnet-1_0_3.jar
jsse-1_0_3.jar
junit-3.8.1.jar
mail-1_3.jar
mailapi-1_3.jar
servlet.jar
xercesImpl-2_4_0.jar
xml-apis-2_4_0.jar

Thanks,
dims

--- Vidyanand Murunikkara <Vidyanand@infravio.com> wrote:
> Thanks Tom
> 
> 1. I have confirmed that the build needs mailapi.jar to compile. Classes
> like DefaultTypeMappingImpl seem to have depenendency on it. So we will
> need to change the build file. 
> 	a) Does it mean we will add mailapi.jar to the lib directory?
> Since activation.jar is not present I presume it is not
> required to be added
> 	b) If attachments are meant to be required should we remove all
> the excludes for compiling in build.xml which depend on 
> 	    attachments being present.
> 
> 2. I cant figure out whats wrong. But i end getting up the error message
> again. 
> 
> Thanks.
> Vidyanand
> -----Original Message-----
> From: Tom Jordahl [mailto:tomj@macromedia.com]
> Sent: Wednesday, November 20, 2002 6:14 AM
> To: 'axis-dev@xml.apache.org'
> Subject: RE: Few questions on the build
> 
> 
> Vidyanand,
> 
> 1. I usually run with all the optional components except security.
> Feel free to add comments to the build.xml and documentation if you
> discover a dependency in the tests that should be documented.  Or fix up
> the code to not require the dependency.
> 
> 2. I don't know why this would happen, probably missing a jar file. SAAJ
> probably requires some of the attachment jars, which are optional in the
> build.
> 
> 3. I develop with JDK 1.3.1.  There are no mandated versions (1.3 or
> higher is probably all we need).  Sticking with 1.3 will prevent you
> from coding any 1.4 dependencies, so I recommend doing that.
> 
> 4. We should NOT care about the parser we use.  JAXP is all we require.
> It would be good to have someone using a parser that is not Xerces.  I
> used Xerces 1.4.4, but recently switched to 2.x.
> 
> Hope this helps.
> 
> --
> Tom Jordahl
> Macromedia Server Development
> 
> 
> 
> -----Original Message-----
> From: Vidyanand Murunikkara [mailto:Vidyanand@infravio.com]
> Sent: Tuesday, November 19, 2002 7:55 PM
> To: axis-dev@xml.apache.org
> Subject: Few questions on the build
> 
> 
> Hi
> 
> 1) In the build.xml there is some notes about optional components. Are
> these required to be in every developers machine? I needed to add
> mailapi.jar to the lib directory to get it compiling. But it is supposed
> to be an optional component. Am I missing something ?
> 
> 2) I tried running "ant clean all-tests" after adding mailapi.jar to the
> lib directory. I end up getting stuck at running the
> tests.saaj.PackageTests. I get a UnsupportedDataTypeException from JAF.
> Again is there somethign possibly wrong with my environment.
> 
> 3) I use JDK 1.4 for development. Is that ok or does Axis mandate a JDK
> 1.3.1 ?
> 
> 4. THe developer's guide requires xerces to be present. Since I use JDK
> 1.4 I already have a JAXP compliant parser. Is that good enough ? ( I
> have read in one of the threads that xerces is preferred ).
> 
> Thanx for taking a look at this and hoping to hear soon :-)
> Vidyanand.


=====
Davanum Srinivas - http://xml.apache.org/~dims/

__________________________________________________
Do you Yahoo!?
Yahoo! Web Hosting - Let the expert host your site
http://webhosting.yahoo.com

Mime
View raw message