axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Spreitzer" <mspre...@us.ibm.com>
Subject Having more trouble with Axis RC1&2: "Problem with servlet engine config file" & JWS doesn't work
Date Tue, 01 Oct 2002 21:23:11 GMT
Now that I've got RC2 passing validation, the next test fails.  Here's my 
Tomcat 4.0.4 typescript:

Starting service Tomcat-Standalone
Apache Tomcat/4.0.4
Starting service Tomcat-Apache
Apache Tomcat/4.0.4
- Problem with servlet engine config file: /WEB-INF/server-config.wsdd

That last line comes out the first time (since starting Tomcat) I try to 
access EchoHeaders.jws or StockQuoteService.jws in my Axis RC2 webapp 
(which I have cleverly named "axis-rc2").  I am trying the access using 
Netscape 4.75 (and thus HTTP GET).  Here's an example URL: 
"http://localhost:8080/axis-rc2/StockQuoteService.jws".  Here is a plain 
text scrape of the returned web page:

AXIS error

No service is available at this URL

Keep in mind, there is no WEB-INF/server-config.wsdd (relative to my Axis 
RC2 webapp) --- RC2 does not come with one, and I did not create one.

I get this result on both Windows 2K and RedHat Linux 7.1.

Still licking my wounds from the XML parser issue, I have tried (and 
gotten the same result) from using both the xerces.jar shipped with Tomcat 
4.0.4 and the xercesImpl.jar and xmlParserAPIs.jar from Xerces 2.0.2. That 
is, I've tried these two as alternates to have in Tomcat's common/lib/.

Am I doing something stupid, or is this a real bug?  I see bugzilla has 
old bugs regarding JWS, but they're marked FIXED.

Thanks,
Mike

Mime
View raw message