axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Daniels <gdani...@macromedia.com>
Subject RE: [VOTE] Bug 13242 merged into 1.0
Date Thu, 03 Oct 2002 15:05:32 GMT
+0, I'm fine with it if others are.

-----Original Message-----
From: Rick Rineholt [mailto:rineholt@us.ibm.com]
Sent: Thursday, October 03, 2002 11:04 AM
To: axis-dev@xml.apache.org
Subject: Re: [VOTE] Bug 13242 merged into 1.0



Since this is not a main line feature  the risk to the product stablity is minor, I assume
this change has runs through our functional test so it's validated the Axis use for it.  Since
it also brings back previous functionality: 

+1

Rick Rineholt
"The truth is out there...  All you need is a better search engine!"

rineholt@us.ibm.com



Please respond to axis-dev@xml.apache.org 


To:        axis-dev@xml.apache.org 
cc:         
Subject:        [VOTE] Bug 13242 merged into 1.0 








I'd like to have this one merged into the 1.0 base because without this
change its a regression/change in behavior and the user has no way of
changing it back.  This fix is very low risk since its pretty much just
added a getter/setter and restoring SimpleAxisServer to its Beta3 behavior.
My vote: +1 .
-Dug


bugzilla@apache.org on 10/03/2002 07:26:19 AM

Please respond to axis-dev@xml.apache.org

To:    axis-dev@xml.apache.org
cc:
Subject:    DO NOT REPLY [Bug 13242] New:  -     SimpleAxisServer's 'start' 
doesn't return anymore


DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13242>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13242

SimpleAxisServer's 'start' doesn't return anymore

Summary: SimpleAxisServer's 'start' doesn't return anymore
Product: Axis
Version: current (nightly) 
Platform: All
OS/Version: Other 
Status: NEW
Severity: Blocker
Priority: Other 
Component: Basic Architecture
AssignedTo: axis-dev@xml.apache.org
ReportedBy: dug@us.ibm.com 


In Beta 3 SimpleAxisServer's start method used to return (spawn a thread).
Since then it was changed to be based on a doThread flag but there is no
way to set this flag w/o going through main() - which some people may
not do (ie. (new SimpleAxisServer()).start() ).
Fix: 
Change doThreads's default value to 'true' to match old behavour
Add get/setDoThreads methods so that people can change the default. 

I marked this as a block/critical because this is a regression in the sense

that it is a change in Axis behavour with no way for the user to switch it
back
(and of course it blocks us  :-)







Mime
View raw message