axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Sitze <rsi...@us.ibm.com>
Subject Re: Using Axis SOAP client from Tomcat/Catalina causes LogConfigurationException...
Date Wed, 25 Sep 2002 20:13:58 GMT
Per,

where did you drop commons-logging.jar OR commons-logging-api.jar (one, 
but NOT both please).  This can happen if you have commons-logging in BOTH 
your host library and your EAR/WAR file(s).

<ras>

*******************************************
Richard A. Sitze
IBM WebSphere WebServices Development




"Per Kreipke" <per@onclave.com>
09/25/2002 03:09 PM
Please respond to axis-dev
 
        To:     <axis-dev@xml.apache.org>
        cc: 
        Subject:        Using Axis SOAP client from Tomcat/Catalina causes 
LogConfigurationException...

 


I'm using Axis RC1 and Tomcat 4.0.4.

I'm trying to use some SOAP client classes built with WSDL2Java from 
within
classes running in Tomcat's server context (e.g. classes that live in
.../jakarta-tomcat-4.0.4/server/classes).

Tomcat starts fine but when the SOAP call is made, I get the following
exception:

org.apache.commons.logging.LogConfigurationException:
  Class org.apache.commons.logging.impl.Log4JCategoryLog does not 
implement
Log

A partial stack trace from my WSDL generated Java is at the bottom of this
email. My guess is that the log returned is null and therefor doesn't 
cast.
But I'm surprised I don't get an NPE instead, so who knows.

Note:

- when I run tests from the command line, using a classpath which points 
to
the axis rc1 'lib' directory, everything is fine.

- tomcat/server/classes contains my .class files

- tomcat/common/lib contains _all_ the axis rc1 jars from 'lib'


I've tried:

- using commons-logging.jar version 1.0.1 instead of the 1.1-dev version
included in AxisRC1. No go.

- dropping a log4j.properties file in [tomcat]/server/classes. No go.

- copied axis.jar (which contains its own log4j.properties) into
[tomcat]/server/lib. No go.

- copied _all_ the Axis jars into [tomcat]/server/lib. No go.


I'm at a loss to explain why it doesn't work. Suggestions?

Per


2002-09-25 15:44:24 HttpProcessor[8080][4] process.invoke
java.lang.ExceptionInInitializerError:
org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Log4JCategoryLog does not implement Log
                 at
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:551)
                 at
org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.ja
va:287)
                 at 
org.apache.commons.logging.LogFactory.getLog(LogFactory.java:409)
                 at 
org.apache.axis.components.logger.LogFactory.getLog(LogFactory.java:77)
                 at
org.apache.axis.configuration.EngineConfigurationFactoryFinder.<clinit>(Engi
neConfigurationFactoryFinder.java:87)
                 at 
org.apache.axis.client.Service.<init>(Service.java:110)
                 at 
CAYENNE.OcwebserviceLocator.<init>(OcwebserviceLocator.java:10)




Mime
View raw message