axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Per Kreipke" <...@onclave.com>
Subject RE: Using Axis SOAP client from Tomcat/Catalina causes LogConfigurationException...
Date Wed, 25 Sep 2002 20:45:04 GMT
> Isn't Tomcat just picking up its commons-logging.jar from
> tomcat/server/lib?  You might have to see whether Tomcat is stable if
> you replace that with the one from Axis rc1.

Scott,

Thanks for the suggestion. You're right, the one in [tomcat]/server/lib
should be used by the 'kernel'.

I'd tried all of these:

    [tomcat]/common/lib         [tomcat]/server/lib

1)  commons-logging 1.0.1-dev   -none-
2)  commons-logging 1.1-dev     -none-

3)  commons-logging 1.0.1-dev   commons-logging 1.0.1-dev
4)  commons-logging 1.1-dev     commons-logging 1.0.1-dev

5)  commons-logging 1.0.1-dev   commons-logging 1.1-dev
6)  commons-logging 1.1-dev     commons-logging 1.1-dev

All caused the same error.

The trick turned out to be Richard's note about having a commons-logging in
your WARs/EARs as well.

When I removed the one in the Cocoon WAR and went back to the ones that
Tomcat and Axis wanted, it worked.

E.g. this worked
    [tomcat]/common/lib         [tomcat]/server/lib

4)  commons-logging 1.1-dev     commons-logging 1.0.1-dev

Richard,

Care to comment about what the problem is? I'm a little unclear.

Per


Mime
View raw message