axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 12747] New: - AdminService generates invalid WSDL
Date Tue, 17 Sep 2002 20:05:09 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12747>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12747

AdminService generates invalid WSDL

           Summary: AdminService generates invalid WSDL
           Product: Axis
           Version: current (nightly)
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Major
          Priority: Other
         Component: WSDL processing
        AssignedTo: axis-dev@xml.apache.org
        ReportedBy: william.pohlmann@vertexinc.com


Generating the WSDL for the AdminService results in wsdl that has undefined 
elements (AdminServiceReturn and xml) for the message definitions.

  <wsdl:message name="AdminServiceResponse">
    <wsdl:part element="AdminServiceReturn" name="AdminServiceReturn"/>
  </wsdl:message>
  <wsdl:message name="AdminServiceRequest">
    <wsdl:part element="xml" name="xml"/>
  </wsdl:message>

This can be shown from feeding the WSDL back into wsdl2java:

C:\devel\axis-9-16>java org.apache.axis.wsdl.WSDL2Java AdminService.wsdl
java.io.IOException: Element {http://schemas.xmlsoap.org/wsdl/}AdminServiceRetur
n is referenced but not defined.
        at org.apache.axis.wsdl.symbolTable.SymbolTable.checkForUndefined(Symbol
Table.java:491)
        at org.apache.axis.wsdl.symbolTable.SymbolTable.add(SymbolTable.java:386
)
        at org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.jav
a:373)
        at org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.jav
a:360)
        at org.apache.axis.wsdl.gen.Parser$WSDLRunnable.run(Parser.java:248)
        at java.lang.Thread.run(Unknown Source)

This occurs both in RC-1 and in the 9/16 build.  You may also want to add RC-1 
as a product version for bugzilla.

Mime
View raw message