axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10609] New: - Ignores underscore when using WSDL2Java tool.
Date Tue, 09 Jul 2002 20:19:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10609>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10609

Ignores underscore when using WSDL2Java tool.

           Summary: Ignores underscore when using WSDL2Java tool.
           Product: Axis
           Version: beta-2
          Platform: All
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: WSDL processing
        AssignedTo: axis-dev@xml.apache.org
        ReportedBy: Saurabh.Mehta@sabre.com
                CC: Saurabh.Mehta@sabre.com


When using WSDL2Java I came across a problem when I was using variables that 
starts with an underscore. The Java2WSDL did create the wsdl file correctly 
with the underscore into considration for element names (under <types>). But 
when I used the same wsdl file to generate the Beans and the stub/skeletons, it 
ignored the underscore and started the variable names from the first character 
after underscore. Please let me know if there is any fix for this bug.

Thanks,
Saurabh Mehta
Saurabh.Mehta@sabre.com

Mime
View raw message