axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "K. Swaminathan" <sw...@instantis.com>
Subject FW: FW: http port doesnt seem to set the port in the header even if it is not 80
Date Fri, 31 May 2002 19:33:47 GMT
All that is missing is the line, that I have added.




         header.append(" HTTP/1.0\r\n")
                 .append(HTTPConstants.HEADER_CONTENT_LENGTH)
                 .append(": ")
                 .append(reqMessage.getContentLength())
                 .append("\r\n")
                 .append(HTTPConstants.HEADER_HOST)
                 .append(": ")
                 .append(host)
     .append(':').append(port)					<==== THIS LINE IS MISSING
                 .append("\r\n")
                 .append(HTTPConstants.HEADER_CONTENT_TYPE)
                 .append(": ")
                 .append(reqMessage.getContentType())
                 .append("\r\n")
                 .append(((otherHeaders == null)? "":
otherHeaders.toString()))
                 .append(HTTPConstants.HEADER_SOAP_ACTION)
                 .append(": \"")
                 .append(action)
                 .append("\"\r\n");


Thanks
Swami K.

->-----Original Message-----
->From: Davanum Srinivas [mailto:dims@yahoo.com]
->Sent: Friday, May 31, 2002 12:00 PM
->To: K. Swaminathan
->Subject: Re: FW: http port doesnt seem to set the port in the header
->even if it is not 80
->
->
->Swami,
->
->Can you send a patch? (directly to the axis-dev@ mailing list) i
->want you to get credit for
->finding the bug.
->
->Thanks,
->dims
->
->--- "K. Swaminathan" <swami@instantis.com> wrote:
->> Hi,
->>
->>  I thought you would be interested in this, Please ignore this mail
->> otherwise
->>
->> thanks
->> Swami K.
->>
->> transport\http\HttpSender.Java in Axis codeline:
->>
->>         header.append(" HTTP/1.0\r\n")
->>                 .append(HTTPConstants.HEADER_CONTENT_LENGTH)
->>                 .append(": ")
->>                 .append(reqMessage.getContentLength())
->>                 .append("\r\n")
->>                 .append(HTTPConstants.HEADER_HOST)
->>                 .append(": ")
->>                 .append(host)                                      <====
->> port is missing here
->>                 .append("\r\n")
->>                 .append(HTTPConstants.HEADER_CONTENT_TYPE)
->>                 .append(": ")
->>                 .append(reqMessage.getContentType())
->>                 .append("\r\n")
->>                 .append(((otherHeaders == null)? "":
->> otherHeaders.toString()))
->>                 .append(HTTPConstants.HEADER_SOAP_ACTION)
->>                 .append(": \"")
->>                 .append(action)
->>                 .append("\"\r\n");
->>
->> ->-----Original Message-----
->> ->From: K. Swaminathan [mailto:swami@instantis.com]
->> ->Sent: Friday, May 31, 2002 11:42 AM
->> ->To:
->> ->Subject: http port doesnt seem to set the port in the header
->even if it
->> ->is not 80
->> ->
->> ->
->> ->Hi,
->> ->
->> ->Looks like transport\http\HttpSender doesnt set the http port in
->> ->the header even if it is not 80. This used to be the bug: 2781 in
->> ->Apache SOAP 2.2 and was fixed by duftler@us.ibm.com. Is this an
->> ->openbug in axis.
->> ->
->> ->Thanks
->> ->Swami K.
->> ->
->> ->PS: I couldnt find the correct address to send this mail, Please
->> ->forward it to the right one if this is not the correct one. Sorry
->> ->about the inconvenience.
->>
->
->
->=====
->Davanum Srinivas - http://xml.apache.org/~dims/
->
->__________________________________________________
->Do You Yahoo!?
->Yahoo! - Official partner of 2002 FIFA World Cup
->http://fifaworldcup.yahoo.com
->


Mime
View raw message