axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran" <stev...@iseran.com>
Subject Re: Okay, I'm lost again.....
Date Thu, 13 Jun 2002 00:08:31 GMT

----- Original Message -----
From: <mseibert@us.ibm.com>
To: <axis-dev@xml.apache.org>
Sent: Wednesday, June 12, 2002 2:12 PM
Subject: Okay, I'm lost again.....


> Doesn't take me long, does it?
>
> I've not got a file called "paths.xml" which looks like this:
>         <path id="classpath">
>           <pathelement location="${xerces.jar}"/>
>           <pathelement location="${regexp.jar}"/>
>           <pathelement location="${junit.jar}"/>
>           <pathelement location="${excalibur.jar}"/>
>           <pathelement location="${java.home}/../lib/tools.jar"/>
>           <fileset dir="lib">
>               <include name="*.jar"/>
>           </fileset>
>           <pathelement path="${java.class.path}"/>
>           <pathelement location="test/foreachTask/bsf.jar" />
>           <pathelement location="test/foreachTask/js.jar" />
>           <pathelement location="${env.ANT_HOME}/lib" />
>         </path>
>
> and I set up the DOCTYPE ENTITY at the top, and added a &paths; into my
> project space.  However, tasks that depend on "classpath" are now failing
> to be found (they are in the classpath, and I guess the classpath name
> isn't referenced?).  Any ideas on what is going wrong here?

as you said in your email, its a matter of going &properties; somewhere.

>           <pathelement location="${env.ANT_HOME}/lib" />

I dont see what that does or why you need it; if you include java.class.path
you get that stuff for free. Also it assumes that the version of ant you are
running=ANT_HOME/lib.ant.jar, which doesnt hold for IDE hosted builds.





Mime
View raw message