axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bihani, Swastik" <Swastik.Bih...@hp.com>
Subject Java2WSDL problem in namespace for bindings
Date Wed, 22 May 2002 22:43:29 GMT
Hi

I am running the WSDL2Java on the following class that comes along with the Apache Soap 2.2
samples.
	samples.mime.MimeTest

However, in the bindings, I'm getting a wrong output:

<wsdl:binding name="MimeTestSoapBinding" type="intf:MimeTest">
      <wsdlsoap:binding style="rpc" transport="http://schemas.xmlsoap.org/soap/http"/>
      <wsdl:operation name="getFileArray">
         <wsdlsoap:operation soapAction=""/>
         <wsdl:input>
            <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="getFileArray"
use="encoded"/>
         </wsdl:input>
         <wsdl:output>
            <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="urn:MimeTest"
use="encoded"/>
         </wsdl:output>
      </wsdl:operation>
      <wsdl:operation name="getFileVector">
         <wsdlsoap:operation soapAction=""/>
         <wsdl:input>
            <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="getFileVector"
use="encoded"/>
         </wsdl:input>
         <wsdl:output>
            <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="urn:MimeTest"
use="encoded"/>
         </wsdl:output>
      </wsdl:operation>
      <wsdl:operation name="listAttachments">
         <wsdlsoap:operation soapAction=""/>
         <wsdl:input>
            <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="listAttachments"
use="encoded"/>
         </wsdl:input>
         <wsdl:output>
            <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="urn:MimeTest"
use="encoded"/>
         </wsdl:output>
      </wsdl:operation>
   </wsdl:binding>

If you see, the namespace for the input operation is the same as the operation name instead
of being "urn:MimeTest" (as is correctly set in the output operation.

Has anyone hit the same problem before??

Regards,
~Swastik

Mime
View raw message