axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vidyanand Murunikkara" <Vidyan...@infravio.com>
Subject RE: Please Help-me - Basic install of Axis Beta2 on Resin 2.1.1 Web Server
Date Wed, 29 May 2002 21:24:11 GMT
Hi Jose

If you take a look at the server-config.wsdd then you will see that in
the <deployment > element there is an invalid attribute "xmlns:" ( for
wsdd namespace, and it appears twice) change it to xmlns and it should
work fine.

Vidyanand.
 

-----Original Message-----
From: Jose Airton F. da Silva [mailto:jairtonfs@hotmail.com]
Sent: Wednesday, May 29, 2002 2:23 PM
To: axis-dev@xml.apache.org; axis-user@xml.apache.org
Cc: snicholnews@scottnichol.com
Subject: Re: Please Help-me - Basic install of Axis Beta2 on Resin 2.1.1
Web Server


Hi Scott Nichol,

I'm still having problem with Axis  and Resin.

My environment is now with Windows 2000 server, Sun JDK 1.3.1, Resin
2.1.1 e
Axis Beta2.

I did this:

 1. Unzip xml-axis-beta2.zip to e:\ (so Axis root is e:\xml-axis-beta2).
 2. Unzip resin-2.1.1.zip  to   e:\ (so Resin root is e:\resin-2.1.1).
 3. xcopy e:\xml-axis-beta2\webapps\axis\*   e:\resin-2.1.1\webapps\axis
/e
(to  make Axis a Resin webapp).
 4. e:\resin-2.1.1\bin\httpd (to start Resin).
 5. Surf to http://localhost:8080/axis - OK - I saw welcome page.
6. Click link to http://localhost:8080/axis/servlet/AxisServlet  - OK -
I
saw some services.

After that I deployed the service. The service name is
"InvertStrService". I
deployed the service successfully with the following command line:

     java
g.apache.axis.client.AdminClient
-lhttp://localhost:8080/axis/services/Adm
inService deploy.wsdd

The Axis engine built the file "server-config.wsdd". This file is in the
e:\Resin-2.1.1\webapps\axis\WEB-INF directory.

After that I tried to surf to
http://localhost:8080/axis/services/InvertStrService?wsdl. It happened a
new
error.

I got the error shown below. I am sending some files to you.

Thansk for help,

Jose.

========================================================================
500 Servlet Exception
org.apache.axis.InternalException:
org.apache.axis.ConfigurationException:
org.apache.axis.deployment.wsdd.WSDDException: java.lang.Exception:
Invalid
WSDD element 'deployment' (wanted 'deployment')
 at org.apache.axis.AxisEngine.init(AxisEngine.java:175)
 at org.apache.axis.AxisEngine.<init>(AxisEngine.java:158)
 at org.apache.axis.server.AxisServer.<init>(AxisServer.java:121)
 at
org.apache.axis.server.DefaultAxisServerFactory.createNewServer(DefaultA
xisS
erverFactory.java:155)
 at
org.apache.axis.server.DefaultAxisServerFactory.getServer(DefaultAxisSer
verF
actory.java:93)
 at org.apache.axis.server.AxisServer.getServer(AxisServer.java:105)
 at
org.apache.axis.transport.http.AxisServlet.getEngine(AxisServlet.java:20
2)
 at
org.apache.axis.transport.http.AxisServlet.getEngine(AxisServlet.java:16
6)
 at
org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:215)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:126)
 at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
 at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.ja
va:9
6)
 at com.caucho.server.http.Invocation.service(Invocation.java:311)
 at
com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
 at
com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:218)
 at
com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:160
)
 at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
 at java.lang.Thread.run(Thread.java:479)
========================================================================
====
==


----- Original Message -----
From: "Scott Nichol" <snicholnews@scottnichol.com>
To: <axis-dev@xml.apache.org>
Sent: Tuesday, May 28, 2002 11:53 PM
Subject: Re: Please Help-me - Basic install of Axis on Web Server Resin
2.1.0


> Jose,
>
> I have similarly had success with Resin 2.1.1 and Axis beta 2 on Red
Hat
7.3
> using the IBM JDK 1.3.1.  I have not defined JAVA_HOME or CLASSPATH.
If
you
> need details on my installation, let me know.
>
> Scott Nichol
>
> ----- Original Message -----
> From: "Scott Nichol" <snicholnews@scottnichol.com>
> To: <axis-dev@xml.apache.org>
> Sent: Tuesday, May 28, 2002 10:19 PM
> Subject: Re: Please Help-me - Basic install of Axis on Web Server
Resin
2.1.0
>
>
> > Jose,
> >
> > I had no problem getting the beta2 distribution of Axis working
under
Resin
> > 2.1.1.  Perhaps there is a problem with 2.1.0?  Working on Windows
2000,
here
> is
> > what I did:
> >
> > 1. Unzip xml-axis-beta2.zip to i:\ (so Axis root is
i:\xml-axis-beta2).
> > 2. Unzip resin-2.1.1.zip to i:\ (so Resin root is i:\resin-2.1.1).
> > 3. xcopy i:\xml-axis-beta2\webapps\axis\*
i:\resin-2.1.1\webapps\axis /e
(to
> > make Axis a Resin webapp).
> > 4. i:\resin-2.1.1\bin\httpd (to start Resin).
> > 5. Surf to http://localhost:8080/axis (to see welcome page).
> > 6. Click link to http://localhost:8080/axis/servlet/AxisServlet (to
see
some
> > services).
> >
> > Other things of note:
> >
> > * I have JAVA_HOME=j:\jdk1.3.1 (the Sun JDK) in my environment.
> > * j:\jdk1.3.1\jre\lib\ext is empty.
> > * I have
> >
CLASSPATH=.;j:\soap-2_2\lib\soap.jar;j:\soap-2_2;j:\xerces-1_2_3\xerces.
jar;
> >
>
k:\progra~1\allaire\jrun\lib\ext\mail.jar;k:\progra~1\allaire\jrun\lib\e
xt\a
ctiv
> > ation.jar;
> > k:\progra~1\allaire\jrun\lib\ext\jaxp.jar
> >
> > As I said, maybe 2.1.1 changes something important from 2.1.0.  Or
perhaps
> there
> > is something about the JDK, environment or OS you are using.  Can
you
post
> some
> > more details about your environment?
> >
> > Scott Nichol
> >


Mime
View raw message