axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Russell Butek" <bu...@us.ibm.com>
Subject Re: DO NOT REPLY [Bug 7612] - Java2WSDL does not work in some cases
Date Tue, 23 Apr 2002 12:42:00 GMT
Rich, you asked whether Java2WSDL should default to 1.1.  That might not be
a bad idea, BUT ... not for beta 2.  It sounds like it could have too many
ramifications.

Russell Butek
butek@us.ibm.com


bugzilla@apache.org on 04/22/2002 05:01:24 PM

Please respond to axis-dev@xml.apache.org

To:    axis-dev@xml.apache.org
cc:
Subject:    DO NOT REPLY [Bug 7612]  -     Java2WSDL does not work in some
       cases



DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7612>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7612

Java2WSDL does not work in some cases





------- Additional Comments From scheu@us.ibm.com  2002-04-22 22:01 -------
Chester: Try using the -T1.1 option to Java2WSDL.  By default the 1.2
mapping
is used, which is causing the soapenc:int mapping for Integer.

You are also correct that xsd:int is flowed over the wire.  This is happens
because the runtime serializer only looks at the java type (Integer)
when trying to determine how to serialize value.  The runtime is using
the 1.1 version of the TypeMapping, which causes it to use xsd:int over the
wire.  In a perfect world, the runtime would use the type information
specified in the wsdl...but the Axis runtime is not wsdl aware.


Russell: Maybe we should change the for Java2WSDL to 1.1 (?) given the
problems
with soapenc imports ?



Mime
View raw message