axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glyn Normington" <glyn_norming...@uk.ibm.com>
Subject Re: Broken GUMP - but no e-mail?
Date Wed, 06 Mar 2002 14:38:48 GMT
I hit that problem last week and just committed a fix [1]. The code was
broken when it was introduced in revision 1.13 of SimpleAxisServer.java, so
I don't know why it ever appeared to work.

Glyn
[1] http://marc.theaimsgroup.com/?l=axis-dev&m=101542290503372&w=2


                                                                                         
                        
                    "Theodore W.                                                         
                        
                    Leung"               To:     axis-dev@xml.apache.org                 
                        
                    <twleung@sauri       cc:                                          
                           
                    a.com>               Subject:     Broken GUMP - but no e-mail?    
                           
                                                                                         
                        
                    05/03/02 19:28                                                       
                        
                    Please respond                                                       
                        
                    to axis-dev                                                          
                        
                                                                                         
                        
                                                                                         
                        



The gump runs for Axis have been failing for the past few days, but
there haven't been any e-mails sent.  Is something broken on the gump
server?

Part of the problem is that the gump run occurs with transparent signing
turned on, and that is masking a problem with the functional tests.

There are still a few issues with the signing stuff, so perhaps its
premature to include it as part of the gump build.

Here's the relevant part of the ant log if you run with signing turned
off.

    [junit] Running
samples.userguide.example6.WidgetPriceServiceTestCase
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 1.366
sec
    [junit] Running samples.addr.AddressBookTestCase
    [junit] - Testing address book sample.
    [junit] Using proxy without session maintenance.
    [junit] >> Storing address for 'Purdue Boilermaker'
    [junit] >> Querying address for 'Purdue Boilermaker'
    [junit] >> Response is:
    [junit]     1 University Drive
    [junit]     West Lafayette, IN 47907
    [junit]     Phone: (765) 494-4900
    [junit] >> Querying address for 'Purdue Boilermaker' again
    [junit] >> Response is:
    [junit]     1 University Drive
    [junit]     West Lafayette, IN 47907
    [junit]     Phone: (765) 494-4900
    [junit] java.lang.Exception: non-session test expected null
response, got sam
ples.addr.Address@20e4119f
    [junit]     at samples.addr.Main.main(Unknown Source)
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 1.336
sec
    [junit]     at samples.addr.AddressBookTestCase.doTest(Unknown
Source)


Ted






Mime
View raw message