axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ajack" <aj...@openbiz.biz>
Subject RE: real AXIS beta 1
Date Wed, 20 Mar 2002 15:29:50 GMT
I wish my e-mail hadn't been down yesterday, 'cos I blew 5+ hours trying to
debug my install.

Note: AXIS alpha 3 was a pleasure to install/use and I appreciate all the
effort that has gone in to this, hence I am slowly typing this long e-mail
w/ my left hand (I broke the right arm) 'cos I hope it might be valuable
feedback.

Since you don't list the problems, and since "misery loves company" ;-), I
figure I'll describe some of my woes in case some of them aren't fixed in
the new spin, and in case this is helpful feedback. I suspect some of my
woes are I have different version of libraries (e.g. log4j/xerces) than you,
but since Java is so bad [worse than M$ w/ DLLs in the bad old days IMHO]
with JAR version identification (yeah right) and dependency checking (none)
I guess I'll not be alone...

I also installed on a brand new environment, so that might be the root of
some of my self caused problems [see log4j later].

I must admit I was "chasing my tail" in some of this, guessing at
problems/solutions [not fun] so take some of this with a pinch of salt. I
never went back to prove a "fix" was indeed a require "fix". That said, I
suspect I am an average "user" in that regard given no real troubleshooting
guide/detailed installation guide (with info on setting up dependencies.)

1) The "copy axis" webapp directory install didn't work on my app server, I
had to manually set things up. Not to bad, I read the WEB-INF/web.xml to
find out most I needed.

2) I went to the index.html page, great, then to each servlet & both crashed
w/ null pointer exception, nothing more useful (other than "log4j not set
up.")

3) Commons Logging

I am familiar w/ log4j, but not commons logging. That unknown added to my
woes. I went to LOG4J site to snarf a copy of a log4j.properties but
unfortunately (I found this out later) I took one of the new ones
[rootLogger != rootCategory] and it didn't work w/ my older LOG4J. That
said, sadly I assumed (chasing my tail, 'cos there was nothing in the
readme/install on commons [nor did I find it on the apache site]) that
commons just didn't work that way, and missed it was a log4j problem.

I spent a lot of time trying to debug. It seems I was getting "class not
loaded" and "class cast exception" from commons. It saw I had log4j
installed, so it picked the Lo4jFactory itself, but it seem to pick an
"older" name for the Log4j "factory" class, i.e. in the commons.logging
package not in the commons.logging.impl package.

Commons logging seems to ship w/ debug classes (great) but the line numbers
in the stack trace did not appear to match the code (shipped in the commons
JAR.) I removed the JAR in the WEB-INF/ tree in favour, just in case that
was old, and used the lib one.

Then it gave these weird cast errors. [Maybe/Probably w/ log4j not configure
right a null not a class was being returned, or something, but a cast was
failing.]

I don't know if this finally fixed it but reading the commons code I found I
could create commons-logging.properties and add a key to set the class of
the Logger to the impl.Log4jXXXXX one. Something in these two, plus fixing
the log4j config file, got me past here.

BTW: Shipping axis beta w/ source (I downloaded) but not with debug classes
seems a tad premature. I know I can build it, but is the performance gain
really worth the obfuscation right now?

4) Crimson vs. XERCES

This is mainly 'cos my app server ships w/ CRIMSON as the default parser,
but I still got null pointer exceptions in AXIS. I saw these with Apache
SOAP 2.2 -- so I tried removing crimson from my classpath, allowing XERCES
to be first, but no joy. However JAXP is used in this drop that "fix" which
seemed to work for AXIS alpha 3 also, no longer seems to. I had to
explicitly override the system properties for the DOM Factory (I did SAX
also) to force AXIS to load the right factory.

Not really an AXIS issue, a local JAXP one I'm sure, but one that caused me
grief, and I was fighting [rather than enjoying AXIS.] AXIS did not give me
clear logs/errors. Ought AXIS state it does not work with CRIMSON (or
perhaps my older CRIMSON)? Again darn Java's lack of JAR
versions/dependencies.

5) server-config.wsdd

After this I had problems 'cos the code could not find a server-config.wsdd.

I hunted around, googled the site and web, and eventually found one
somewhere in the drop. I copied it into place, it failed 'cos it was read
only. I fixed that, and it failed worse. It complained a lot about "need to
set a 'type' attribute on a deployment' ... something or other. (noType00 or
similar.) I wondered if I was perhaps having problems w/ me XERCES (too old?
too new?) and attributes. Reading the code didn't help, this was buried down
deep, no clues. I had full log4j debug on by now, but got nothing else. I
tried with and without the file, no good. I finally commented out most of
the file, and ..... TADA!!! It worked. :-)  [Later I came back and found the
file re-written and empty, sans top XML node, but still working.]

I could start/stop via Admin and "talk" to the AxisServlet.

6) AdminClient

I was unable to even do a "list" (let alone deploy). I receive a "null
response" and even with full log4j debug on [it showed the right URL] and
the TCP Monitor all I could tell was that there was no HTTP request going to
the server. I ran out of time here, but also ran out of ideas. Nothing but
"null response" was reported.

	---------------------------------------------------------------------------
----------------------

Final note: I know (from my own system) that user friend logging is really
tough --- there is often too much or too little, too high or low level. I
know this matures over time (with user feedback) so please accept this
feedback: Please try to test more for "bad installation (missing/old XYZ)
failure cases" and "please try to log more", at all levels.

Now off to download the new beta. Wish me luck... ;-)

regards

Adam
-----Original Message-----
From: Russell Butek [mailto:butek@us.ibm.com]
Sent: Tuesday, March 19, 2002 3:40 PM
To: axis-dev@xml.apache.org; axis-user@xml.apache.org
Subject: real AXIS beta 1


The real AXIS beta 1 is now available -
http://xml.apache.org/axis/dist/beta1/.

The beta1 released Friday was really release candidate 3 - we found a
couple serious problems with it - documentation and code - that warranted a
respin of the beta.  Today's, however, is the FINAL Beta 1 (really!  I
promise!).  We will probably do a few more betas before we release 1.0, and
these should not be much more than 1 month apart.  This way if we find
serious problems you won't have to wait very long for the next official
release.

Russell Butek
butek@us.ibm.com


Mime
View raw message