axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Russell Butek" <bu...@us.ibm.com>
Subject Re: Consuming a .NET service with axis
Date Tue, 29 Jan 2002 18:32:30 GMT
Could you provide the WSDL file that's giving you these problems?

Russell Butek
butek@us.ibm.com


"Jorge Balderas" <jorge.balderas@verizon.net> on 01/29/2002 11:50:10 AM

Please respond to axis-dev@xml.apache.org

To:    <axis-dev@xml.apache.org>
cc:
Subject:    Consuming a .NET service with axis



Hello. I'm a programmer learning about web services. I'm trying to
integrate
a Web Service exposed with .NET and to be consumed using AXIS. I did the
reverse experiment and had no problems.

I'm using the wsdl2java tool, however when trying to compile the java files
generated, I'm getting "cannot resolve symbol" errors for the class
ServiceResponse_Type, which makes sense because it does not exist in the
generated files.

I tried generating the stub files from a .jws file from Axis, and I'm able
to compile these files. When I compared the WSDL files from the .jws and
the
.asmx file (from .NET), then I noticed that in the WSDL from the .NET
service, all the types are initially declared as complex types and then
bound in the messages section.

I was initially using decimal type from VisualBasic, but I also tried using
just integers and I still have the same problem. Could somebody tell which
is the most appropriate way of solving this issue?

Thanks a lot!

Jorge




Mime
View raw message