axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Roder <mro...@wamnet.com>
Subject Issue - double encodingStyle in envelope
Date Wed, 16 Jan 2002 14:50:07 GMT

I am getting soap packets that list the encodingStyle twice.

I didn't have this problem on the code base from 30 Dec 01 code .  I do have
this problem on the 16 Jan 02 code base.

Example:
POST /cgi-bin/foo HTTP/1.0 Content-Length: 506 Host: foo Content-Type:
text/xml; charset=utf-8 SOAPAction: ""  <?xml version="1.0"
encoding="UTF-8"?>
<SOAP-ENV:Envelope
SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <SOAP-ENV:Body>
  <Login>
   <User>
    <UserID>foo</UserID>
    <Password>foo</Password>
   </User>
  </Login>
 </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

This is the first time through, so a new service, new call, etc.

The code boils down to the following:
  Service service = new Service();
    Call aCall = (Call) service.createCall();
    aCall.setTargetEndpointAddress(url);
    aCall.setOption(AxisEngine.PROP_DOMULTIREFS, Boolean.FALSE);
    aCall.setOption(AxisEngine.PROP_SEND_XSI, Boolean.FALSE);
    aCall.setOption(Call.SEND_TYPE_ATTR, Boolean.FALSE);
    aCall.addSerializer(User.class,new QName(),new
BeanSerializer(User.class,BeanSerializer.FORCE_UPPER));
    RPCParam userParam = new RPCParam("User", aUser) ;
    String ret = (String)aCall.invoke("Login",
		  new Object []  {userParam });
	
 
Later

Mark



Mime
View raw message