axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Daniels <gdani...@macromedia.com>
Subject Build failure (ATTN: WSDL guys!)
Date Mon, 03 Dec 2001 19:00:23 GMT

Faults like this are occuring during the functional-tests:

     [java] <ns1:Fault
xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/">
     [java]    <ns1:faultcode
xmlns:ns1="http://xml.apache.org/axis/">ns1:Server.userException</ns1:faultc
ode>
     [java]    <ns1:faultstring>; nested exception is:
     [java]    AxisFault
     [java]   faultCode: http://xml.apache.org/axis/:Server.generalException
     [java]   faultString: mssoapinterop.interopc.SOAPStruct
     [java]   faultActor: null
     [java]   faultDetail:
     [java] </ns1:faultstring>
     [java]    <ns1:detail>
     [java]     <ns2:exceptionName
xmlns:ns2="http://xml.apache.org/axis/">org.apache.axis.AxisFault</ns2:excep
tionName>
     [java]     <ns3:stackTrace
xmlns:ns3="http://xml.apache.org/axis/">AxisFault
     [java]   faultCode: http://xml.apache.org/axis/:Server.generalException
     [java]   faultString: mssoapinterop.interopc.SOAPStruct
     [java]   faultActor: null
     [java]   faultDetail:
     [java]    stackTrace: AxisFault
     [java]   faultCode: http://xml.apache.org/axis/:Server.generalException
     [java]   faultString: mssoapinterop.interopc.SOAPStruct
     [java]   faultActor: null
     [java]   faultDetail:
     [java] &#xd;
     [java]    at
org.apache.axis.deployment.wsdd.WSDDDeployment.deployMappingToRegistry(WSDDD
eployment.java:239)&#xd;
     [java]    at
org.apache.axis.deployment.wsdd.WSDDDeployment.deployToRegistry(WSDDDeployme
nt.java:200)&#xd;
     [java]    at
org.apache.axis.deployment.wsdd.WSDDDocument.deploy(WSDDDocument.java:172)&#
xd;
     [java]    at
org.apache.axis.deployment.SimpleDeploymentManager.deploy(SimpleDeploymentMa
nager.java:122)&#xd;
     [java]    at
org.apache.axis.AxisEngine.deployWSDD(AxisEngine.java:328)&#xd;
     [java]    at
org.apache.axis.utils.Admin.processWSDD(Admin.java:308)&#xd;
     [java]    at org.apache.axis.utils.Admin.process(Admin.java:382)&#xd;
     [java]    at
org.apache.axis.utils.Admin.AdminService(Admin.java:178)&#xd;
     [java]    at java.lang.reflect.Method.invoke(Native Method)&#xd;
     [java]    at
org.apache.axis.providers.java.MsgProvider.processMessage(MsgProvider.java:1
77)&#xd;
     [java]    at
org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:242)&#x
d;
     [java]    at
org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:253)&#xd;
     [java]    at
org.apache.axis.server.AxisServer.invoke(AxisServer.java:254)&#xd;
     [java]    at
org.apache.axis.transport.http.SimpleAxisServer.run(SimpleAxisServer.java:37
1)&#xd;
     [java]    at
org.apache.axis.transport.http.SimpleAxisServer.main(SimpleAxisServer.java:7
96)&#xd;
     [java]
     [java] &#xd;
     [java] AxisFault
     [java]   faultCode: http://xml.apache.org/axis/:Server.generalException
     [java]   faultString: mssoapinterop.interopc.SOAPStruct
     [java]   faultActor: null
     [java]   faultDetail:
     [java] &#xd;
     [java]    at
org.apache.axis.deployment.wsdd.WSDDDeployment.deployMappingToRegistry(WSDDD
eployment.java:239)&#xd;
     [java]    at
org.apache.axis.deployment.wsdd.WSDDDeployment.deployToRegistry(WSDDDeployme
nt.java:200)&#xd;
     [java]    at
org.apache.axis.deployment.wsdd.WSDDDocument.deploy(WSDDDocument.java:172)&#
xd;
     [java]    at
org.apache.axis.deployment.SimpleDeploymentManager.deploy(SimpleDeploymentMa
nager.java:122)&#xd;
     [java]    at
org.apache.axis.AxisEngine.deployWSDD(AxisEngine.java:328)&#xd;
     [java]    at
org.apache.axis.utils.Admin.processWSDD(Admin.java:308)&#xd;
     [java]    at org.apache.axis.utils.Admin.process(Admin.java:382)&#xd;
     [java]    at
org.apache.axis.utils.Admin.AdminService(Admin.java:178)&#xd;
     [java]    at java.lang.reflect.Method.invoke(Native Method)&#xd;
     [java]    at
org.apache.axis.providers.java.MsgProvider.processMessage(MsgProvider.java:1
77)&#xd;
     [java]    at
org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:242)&#x
d;
     [java]    at
org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:253)&#xd;
     [java]    at
org.apache.axis.server.AxisServer.invoke(AxisServer.java:254)&#xd;
     [java]    at
org.apache.axis.transport.http.SimpleAxisServer.run(SimpleAxisServer.java:37
1)&#xd;
     [java]    at
org.apache.axis.transport.http.SimpleAxisServer.main(SimpleAxisServer.java:7
96)&#xd;
     [java] </ns3:stackTrace>
     [java]    </ns1:detail>
     [java]   </ns1:Fault>

There are several issues that come up as a result.

1) Something is going wrong with the test.  It appears that the
mssoapinterop.interopb.SOAPStruct type may not be getting generated (I don't
see it in my source tree) - WSDL guys, can you look into this?  Maybe run
the test manually, see if it behaves reasonably?

2) The functional tests complete successfully despite these failures.  This
should be fixed.  I tried setting "failonerror='yes'" in
build-functional-tests.xml, but that didn't seem to do it... any ideas?

3) The fault output is repetitive and noisy.  I'll look into improving this.

--Glen

Mime
View raw message