axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glen Daniels" <gdani...@macromedia.com>
Subject Re: Broken build.
Date Mon, 12 Nov 2001 18:20:26 GMT
Tom - this was because we serialized the message twice (once to log it, once
to send it on the wire), and I had a bug in my code which accumulated
encodingstyle attributes in the MessageElement's contained attribute list
during serialization.  This is now fixed, as I hope are some of the other
related problems with encodingStyle and interop - we now write the
encodingStyle as an envelope attribute when there are RPCElements in the
body.

--Glen

----- Original Message -----
From: "Tom Jordahl" <tomj@macromedia.com>
To: <axis-dev@xml.apache.org>
Sent: Monday, November 12, 2001 1:04 PM
Subject: RE: Broken build.


>
> OK - I take it back.
>
> I was plying around with the log4j configuration file.
> When I reset it back to the CVS version of log4j.properties, everything
> works.
>
> Anyone know why log4j would affect the XML on the wire?
>
> --
> Tom Jordahl
>
>
> -----Original Message-----
> From: Tom Jordahl [mailto:tomj@macromedia.com]
> Sent: Monday, November 12, 2001 12:55 PM
> To: 'axis-dev@xml.apache.org'
> Subject: Broken build.
>
>
>
> I am getting failures for 'ant clean all' and in my testing because of the
> following XML getting sent from the client to the server
>
> <?xml version="1.0" encoding="UTF-8"?>
> <SOAP-ENV:Envelope
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>  <SOAP-ENV:Body>
>   <ns3:getQuote
> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:ns3="urn:xmltoday-delayed-quotes">
>    <symbol xsi:type="xsd:string">MACR</symbol>
>    </ns3:getQuote>
>   </SOAP-ENV:Body>
>  </SOAP-ENV:Envelope>
>
> Notice the extra "SOAP-ENV" in the getQuote Body.
>
> Anyone want to take ownership of this bug?
>
>
> --
> Tom Jordahl
> Macromedia Server Development
>


Mime
View raw message