axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Russell Butek" <bu...@us.ibm.com>
Subject Re: Use of java.util.Iterator?
Date Wed, 31 Oct 2001 12:57:29 GMT
It's not a requirement to support JDK 1.1.  In fact, though I don't
remember the reasons offhand (dynamic proxy?), some folks think we
shouldn't bother supporting anything before JDK 1.3.

Russell Butek
butek@us.ibm.com


"R. Mark Volkmann" <volkmann2@home.com> on 10/31/2001 04:31:22 AM

Please respond to axis-dev@xml.apache.org

To:   <axis-dev@xml.apache.org>
cc:
Subject:  Re: Use of java.util.Iterator?



----- Original Message -----
From: "Rob Jellinghaus" <robj@unrealities.com>
To: <axis-dev@xml.apache.org>
Sent: Tuesday, October 30, 2001 7:33 PM
Subject: Use of java.util.Iterator?


> Is it a requirement (and/or, currently the case) that Axis be JDK 1.1
compliant?
>
> Some of the JAXM API's use java.util.Iterator, which pretty much
eliminates 1.1 compliance.  The question is whether I should do likewise,
in
emulating those API's in Axis.

I don't think it's important for AXIS to be compatible with JDK 1.1.




Mime
View raw message