axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew J. Duftler" <duft...@watson.ibm.com>
Subject RE: Runtime bugs in current CVS base?
Date Tue, 29 May 2001 20:07:24 GMT
Hi Darrel,

If you're using Ant 1.3, go to: \jakarta-ant-1.3\docs\manual\install.html
and look at the 2nd paragraph under System Requirements. In short, you
probably need to move the jaxp.jar and parser.jar out of the
\jakarta-ant-1.3\lib directory.

By running:

javap -classpath parser.jar org.w3c.dom.Element

in the lib directory, it appears that the parser.jar contains a
non-namespace-aware DOM implementation.

Thanks,
-Matt

> -----Original Message-----
> From: Darrel Drake [mailto:EB92401@jp.ibm.com]
> Sent: Tuesday, May 29, 2001 4:26 AM
> To: axis-dev@xml.apache.org
> Subject: Runtime bugs in current CVS base?
>
>
>
> I have two problems. I'll start with the general one:
>
> I downloaded a new cvs snapshot about a week ago, and was
> able to build it from scratch using ant as I always do
> nowadays. I then played around with some things, and also
> updated the files from CVS (successfully avoided my particular
> conflicts). I ran ant again and was able to successfully
> compile. Then I went to run the stock sample and got a series
> of SAXExceptions: the first tag was <head> instead of
> <SOAP-ENV:envelope>. This problem was re-confirmed on
> another machine in TRL using today's build, so I'd like to know
> if any of you also have trouble running
> samples/stock/testit.cmd or the Unix equivalent with the
> current cvs package.
>
> Now a problem that makes me say "maybe it's just me":
>
> Thinking the first problem might go away, I went and downloaded
> a new copy of the cvs tree to another directory. I tried
> compiling it from scratch and got 35 errors, all of which seem to
> relate to DOM-1 vs. DOM-2 issues. Here's one of the messages:
>
> [javac] D:
> \xml-axis\newcvstree\xml-axis\java\src\org\apache\axis\utils\XMLUt
> ils.java:269:
>
> cannot resolve symbol
> [javac] symbol  : method getAttributeNS
> (java.lang.String,java.lang.String)
> [javac] location: interface org.w3c.dom.Element
> [javac]               ((Element)e).getAttributeNS(Constants.NS_URI_XMLNS,
> prefix);
> [javac]               ^
>
> The weird thing is when I run javap on my xerces.jar file, it shows
> the method with the correct signature, so it seems that an older
> version of xerces is getting picked up from *somewhere* (?).
> So I checked and double-checked my jre/lib/ext directory for
> any incorrect DOM stuff and found none, cleaned out my classpath
> to just the essentials, and installed the latest Xerces (1.4.0) and
> Xalan (1.2.1). None of these changes made any difference in my
> compilation output. I have some older IBM JDKs on my machine
> that contain the old XML4J (and which I'm reluctant to remove
> forever), but they aren't pointed to by my java_home or my
> classpath. Ryo was able to compile it from scratch, so I suppose
> there must be some other setup issue. If anyone has a clue about
> this one please please help.
>
> Darrell Drake*
> IBM Japan, TRL
> +81-46-215-4175
> EB92401@jp.ibm.com
> * - Notes ID has a misspelling of my name
>


Mime
View raw message