axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Davis" <...@us.ibm.com>
Subject Re: is axis working?
Date Tue, 17 Apr 2001 21:54:03 GMT
What parser (and version of that parser) are you using?  We don't anything
with the parsed xml we just pass it along to the server so its really
strange
that its getting almost everything - seems like it should be an all or
nothing deal.
-Dug


Morgan Delagrange <morgand@apache.org> on 04/17/2001 05:15:24 PM

Please respond to axis-dev@xml.apache.org

To:   axis-dev@xml.apache.org
cc:
Subject:  Re: is axis working?



Hi all,

Here's some follow-up.  I found your debug mode on the AdminClient program
and ran it.  This certainly doesn't look good:

XML sent:
---------------------------------------------------
POST /axis/servlet/AxisServlet HTTP/1.0
Content-Length: 734
Content-Type: text/xml
SOAPAction: "AdminService"

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope
SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Heade
r><d:Debug
SOAP-ENV:actor="http://schemas.xmlsoap.org/soap/actor/next" xmlns:d="
http://xml.apache.org/axis/debug
">1</d:Debug></SOAP-ENV:Header><SOAP-ENV:Body><deploy>
  <handler class="" name=""/>
  <handler class="" name=""/>
  <chain flow="" name=""/>
  <chain flow="" name=""/>

  <service name="" pivot="">
    <option name="" value=""/>
    <option name="" value=""/>
  </service>
  <service name="" pivot="">
    <option name="" value=""/>
    <option name="" value=""/>
  </service>
</deploy></SOAP-ENV:Body></SOAP-ENV:Envelope>

It looks like something's wrong with your XML parsing, or with how it's
being serialized in debug mode.

On Tue, 17 Apr 2001, Morgan Delagrange wrote:

> These errors are based on the 4-17 build.  I take it that those samples
> should be working?
>
> Server side error:
>
> java.lang.NullPointerException
>         at java.util.Hashtable.get(Hashtable.java:320)
>         at
> org.apache.tomcat.loader.AdaptiveClassLoader.loadClass(AdaptiveClassL
> oader.java:424)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
>         at
> org.apache.axis.utils.AxisClassLoader.loadClass(AxisClassLoader.java:
> 121)
>         at org.apache.axis.utils.Admin.process(Admin.java:237)
>         at org.apache.axis.utils.Admin.process(Admin.java:119)
>         at org.apache.axis.utils.Admin.AdminService(Admin.java:113)
>         at java.lang.reflect.Method.invoke(Native Method)
>         at
> org.apache.axis.handlers.MsgDispatchHandler.invoke(MsgDispatchHandler
> .java:131)
>         at
> org.apache.axis.handlers.SOAPServerHandler.invoke(SOAPServerHandler.j
> ava:112)
>         at org.apache.axis.server.AxisServer.invoke(AxisServer.java:189)
>         at
> org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:17
> 0)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
>         at
> org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:4
> 04)
>         at org.apache.tomcat.core.Handler.service(Handler.java:286)
>         at
> org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372
> )
>         at
> org.apache.tomcat.core.ContextManager.internalService(ContextManager.
> java:797)
>         at
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:743
> )
>         at
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnectio
> n(HttpConnectionHandler.java:210)
>         at
> org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:
> 416)
>         at
> org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java
> :498)
>         at java.lang.Thread.run(Thread.java:484)
>
> client side error:
>
> <?xml version="1.0" encoding="UTF-8"?>
>
<SOAP-ENV:Fault><faultcode>Server.generalException</faultcode><faultstring>java.

> lang.reflect.InvocationTargetException: org.apache.axis.AxisFault
>         at org.apache.axis.utils.Admin.process(Admin.java:377)
>         at org.apache.axis.utils.Admin.process(Admin.java:119)
>         at org.apache.axis.utils.Admin.AdminService(Admin.java:113)
>         at java.lang.reflect.Method.invoke(Native Method)
>         at
> org.apache.axis.handlers.MsgDispatchHandler.invoke(MsgDispatchHandler
> .java:131)
>         at
> org.apache.axis.handlers.SOAPServerHandler.invoke(SOAPServerHandler.j
> ava:112)
>         at org.apache.axis.server.AxisServer.invoke(AxisServer.java:189)
>         at
> org.apache.axis.transport.http.AxisServlet.doPost(AxisServlet.java:17
> 0)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
>         at
> org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:4
> 04)
>         at org.apache.tomcat.core.Handler.service(Handler.java:286)
>         at
> org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372
> )
>         at
> org.apache.tomcat.core.ContextManager.internalService(ContextManager.
> java:797)
>         at
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:743
> )
>         at
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnectio
> n(HttpConnectionHandler.java:210)
>         at
> org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:
> 416)
>         at
> org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java
> :498)
>         at java.lang.Thread.run(Thread.java:484)
> </faultstring></SOAP-ENV:Fault>
>
>
> On Tue, 17 Apr 2001, Doug Davis wrote:
>
> > What's the exact error message?
> > -Dug
> >
> > Morgan Delagrange <morgand@apache.org> on 04/17/2001 01:15:25 PM
> >
> > Please respond to axis-dev@xml.apache.org
> >
> > To:   axis-dev@xml.apache.org
> > cc:
> > Subject:  is axis working?
> >
> >
> >
> > Hi all,
> >
> > Do the daily builds function yet?  I've tried to deploy the
> > StockQuoteService class using the following XML:
> >
> > <deploy>
> >   <handler name="authen"
> > class="org.apache.axis.handlers.SimpleAuthenticationHandler" />
> >   <handler name="author"
> > class="org.apache.axis.handlers.SimpleAuthorizationHandler" />
> >   <chain name="checks"  flow="authen,author" />
> >   <chain name="rpc"  flow="checks,RPCDispatcher" />
> >   <service name="urn:xmltoday-delayed-quotes" pivot="rpc" >
> >     <option name="className" value="samples.stock.StockQuoteService" />
> >     <option name="methodName" value="getQuote" />
> >   </service>
> > </deploy>
> >
> > but I keep getting class loader exceptions on the server side, despite
> > having the StockQuoteService class in the
> > /WEB-INF/classes/samples/stock directory of the axis webapp.  Any
ideas?
> >
> >
> >
> >
>
>




Mime
View raw message