axis-java-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From veit...@apache.org
Subject svn commit: r1029153 - in /axis/axis2/java/core/trunk/modules: parent/pom.xml tool/axis2-eclipse-codegen-plugin/pom.xml tool/axis2-eclipse-service-plugin/pom.xml
Date Sat, 30 Oct 2010 18:48:11 GMT
Author: veithen
Date: Sat Oct 30 18:48:11 2010
New Revision: 1029153

URL: http://svn.apache.org/viewvc?rev=1029153&view=rev
Log:
Replaced the Eclipse dependencies with artifacts available from Maven central, and removed
the Eclipse repository. As noted by Isuru, for some unknown reason, the trunk was no longer
buildable with an empty local Maven repository. This changes fixes this issue.

Modified:
    axis/axis2/java/core/trunk/modules/parent/pom.xml
    axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-codegen-plugin/pom.xml
    axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-service-plugin/pom.xml

Modified: axis/axis2/java/core/trunk/modules/parent/pom.xml
URL: http://svn.apache.org/viewvc/axis/axis2/java/core/trunk/modules/parent/pom.xml?rev=1029153&r1=1029152&r2=1029153&view=diff
==============================================================================
--- axis/axis2/java/core/trunk/modules/parent/pom.xml (original)
+++ axis/axis2/java/core/trunk/modules/parent/pom.xml Sat Oct 30 18:48:11 2010
@@ -81,7 +81,6 @@
         <commons.httpclient.version>3.1</commons.httpclient.version>
         <commons.io.version>1.4</commons.io.version>
         <commons.logging.version>1.1.1</commons.logging.version>
-        <eclipse.version>3.2.0</eclipse.version>
         <fi.version>1.2.7</fi.version>
         <geronimo.spec.activation.version>1.0.2</geronimo.spec.activation.version>
         <geronimo.spec.annotation.version>1.1</geronimo.spec.annotation.version>
@@ -441,18 +440,6 @@
           Checksum policy when not specified always defaults to 'warn'
           which is what we want.
        -->
-        <repository>
-            <id>eclipse-repo</id>
-            <name>eclipse maven repository</name>
-            <url>http://repo1.maven.org/eclipse</url>
-            <releases>
-                <enabled>true</enabled>
-                <updatePolicy>never</updatePolicy>
-            </releases>
-            <snapshots>
-                <enabled>false</enabled>
-            </snapshots>
-        </repository>
         <!--repository>
             <id>java.net</id>
             <url>http://download.java.net/maven/2/</url>
@@ -845,48 +832,68 @@
             </dependency>
             <dependency>
                 <groupId>org.eclipse.core</groupId>
-                <artifactId>org.eclipse.core.jobs</artifactId>
-                <version>${eclipse.version}</version>
+                <artifactId>jobs</artifactId>
+                <version>3.2.0-v20060603</version>
             </dependency>
             <dependency>
                 <groupId>org.eclipse.core</groupId>
-                <artifactId>org.eclipse.core.resources</artifactId>
-                <version>${eclipse.version}</version>
+                <artifactId>resources</artifactId>
+                <version>3.2.1-R32x_v20060914</version>
             </dependency>
             <dependency>
                 <groupId>org.eclipse.core</groupId>
-                <artifactId>org.eclipse.core.runtime</artifactId>
-                <version>${eclipse.version}</version>
+                <artifactId>runtime</artifactId>
+                <version>3.2.0-v20060603</version>
             </dependency>
             <dependency>
                 <groupId>org.eclipse.equinox</groupId>
-                <artifactId>org.eclipse.equinox.common</artifactId>
-                <version>${eclipse.version}</version>
+                <artifactId>common</artifactId>
+                <version>3.2.0-v20060603</version>
             </dependency>
             <dependency>
-                <groupId>org.eclipse.jface</groupId>
-                <artifactId>org.eclipse.jface</artifactId>
-                <version>${eclipse.version}</version>
+                <groupId>org.eclipse</groupId>
+                <artifactId>jface</artifactId>
+                <version>3.2.1-M20060908-1000</version>
             </dependency>
             <dependency>
-                <groupId>org.eclipse.osgi</groupId>
-                <artifactId>org.eclipse.osgi</artifactId>
-                <version>${eclipse.version}</version>
+                <groupId>org.eclipse</groupId>
+                <artifactId>osgi</artifactId>
+                <version>3.2.1-R32x_v20060919</version>
             </dependency>
             <dependency>
-                <groupId>org.eclipse.swt</groupId>
-                <artifactId>org.eclipse.swt</artifactId>
-                <version>${eclipse.version}</version>
+                <groupId>org.eclipse</groupId>
+                <artifactId>swt</artifactId>
+                <version>3.2.1-v3235e</version>
             </dependency>
             <dependency>
-                <groupId>org.eclipse.swt</groupId>
-                <artifactId>org.eclipse.swt.win32.win32.x86</artifactId>
-                <version>${eclipse.version}</version>
+                <groupId>org.eclipse.swt.win32.win32</groupId>
+                <artifactId>x86</artifactId>
+                <version>3.2.1-v3235</version>
             </dependency>
             <dependency>
                 <groupId>org.eclipse.ui</groupId>
-                <artifactId>org.eclipse.ui.ide</artifactId>
-                <version>${eclipse.version}</version>
+                <artifactId>ide</artifactId>
+                <version>3.2.1-M20060915-1030</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse.core</groupId>
+                <artifactId>expressions</artifactId>
+                <version>3.2.1-r321_v20060721</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse</groupId>
+                <artifactId>ui</artifactId>
+                <version>3.2.1-M20060913-0800</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse.ui</groupId>
+                <artifactId>workbench</artifactId>
+                <version>3.2.1-M20060906-0800</version>
+            </dependency>
+            <dependency>
+                <groupId>org.eclipse.update</groupId>
+                <artifactId>core</artifactId>
+                <version>3.2.1-v20092006</version>
             </dependency>
             <dependency>
                 <groupId>com.intellij</groupId>

Modified: axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-codegen-plugin/pom.xml
URL: http://svn.apache.org/viewvc/axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-codegen-plugin/pom.xml?rev=1029153&r1=1029152&r2=1029153&view=diff
==============================================================================
--- axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-codegen-plugin/pom.xml (original)
+++ axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-codegen-plugin/pom.xml Sat Oct 30
18:48:11 2010
@@ -39,111 +39,39 @@
     <dependencies>
         <dependency>
             <groupId>org.eclipse.core</groupId>
-            <artifactId>org.eclipse.core.jobs</artifactId>
-            <exclusions>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.commands</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.variables</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.contenttype</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.expressions</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.filesystem</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.update</groupId>
-                    <artifactId>org.eclipse.update.ui</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.update</groupId>
-                    <artifactId>org.eclipse.update.configurator</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.update</groupId>
-                    <artifactId>org.eclipse.update.core</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.help</groupId>
-                    <artifactId>org.eclipse.help</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.ant</groupId>
-                    <artifactId>org.eclipse.ant.core</artifactId>
-                </exclusion>
-            </exclusions>
+            <artifactId>jobs</artifactId>
         </dependency>
         <dependency>
             <groupId>org.eclipse.core</groupId>
-            <artifactId>org.eclipse.core.resources</artifactId>
+            <artifactId>resources</artifactId>
         </dependency>
         <dependency>
             <groupId>org.eclipse.core</groupId>
-            <artifactId>org.eclipse.core.runtime</artifactId>
-            <exclusions>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.runtime.compatibility</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.runtime.compatibility.auth</artifactId>
-                </exclusion>
-            </exclusions>
+            <artifactId>runtime</artifactId>
         </dependency>
         <dependency>
             <groupId>org.eclipse.equinox</groupId>
-            <artifactId>org.eclipse.equinox.common</artifactId>
-            <exclusions>
-                <exclusion>
-                    <groupId>org.eclipse.equinox</groupId>
-                    <artifactId>org.eclipse.equinox.registry</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.equinox</groupId>
-                    <artifactId>org.eclipse.equinox.preferences</artifactId>
-                </exclusion>
-            </exclusions>
+            <artifactId>common</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.jface</groupId>
-            <artifactId>org.eclipse.jface</artifactId>
+            <groupId>org.eclipse</groupId>
+            <artifactId>jface</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.osgi</groupId>
-            <artifactId>org.eclipse.osgi</artifactId>
+            <groupId>org.eclipse</groupId>
+            <artifactId>osgi</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.swt</groupId>
-            <artifactId>org.eclipse.swt</artifactId>
+            <groupId>org.eclipse</groupId>
+            <artifactId>swt</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.swt</groupId>
-            <artifactId>org.eclipse.swt.win32.win32.x86</artifactId>
+            <groupId>org.eclipse.swt.win32.win32</groupId>
+            <artifactId>x86</artifactId>
         </dependency>
         <dependency>
             <groupId>org.eclipse.ui</groupId>
-            <artifactId>org.eclipse.ui.ide</artifactId>
-            <exclusions>
-                <exclusion>
-                    <groupId>org.eclipse.ui</groupId>
-                    <artifactId>org.eclipse.ui.forms</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.ui</groupId>
-                    <artifactId>org.eclipse.ui.views</artifactId>
-                </exclusion>
-            </exclusions>
+            <artifactId>ide</artifactId>
         </dependency>
         <dependency>
             <groupId>${project.groupId}</groupId>
@@ -257,7 +185,7 @@
                     <manifestLocation>META-INF</manifestLocation>
                     <instructions>
                         <!-- Embed all dependencies, except those which are provided by
the Eclipse runtime -->
-                        <Embed-Dependency>*;scope=compile|runtime;artifactId=!org.eclipse.*|commons-logging|wstx-asl|geronimo-activation_1.1_spec|geronimo-javamail_1.4_spec|geronimo-stax-api_1.0_spec|ant*</Embed-Dependency>
+                        <Embed-Dependency>*;scope=compile|runtime;groupId=!org.eclipse.*;artifactId=!commons-logging|wstx-asl|geronimo-activation_1.1_spec|geronimo-javamail_1.4_spec|geronimo-stax-api_1.0_spec|ant*</Embed-Dependency>
                         <Embed-Directory>lib</Embed-Directory>
                         <Embed-Transitive>true</Embed-Transitive>
                         <!-- Exclude imports that are actually not used -->

Modified: axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-service-plugin/pom.xml
URL: http://svn.apache.org/viewvc/axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-service-plugin/pom.xml?rev=1029153&r1=1029152&r2=1029153&view=diff
==============================================================================
--- axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-service-plugin/pom.xml (original)
+++ axis/axis2/java/core/trunk/modules/tool/axis2-eclipse-service-plugin/pom.xml Sat Oct 30
18:48:11 2010
@@ -44,95 +44,27 @@
         </dependency>
         <dependency>
             <groupId>org.eclipse.core</groupId>
-            <artifactId>org.eclipse.core.runtime</artifactId>
-            <exclusions>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.commands</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.variables</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.contenttype</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.expressions</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.filesystem</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.update</groupId>
-                    <artifactId>org.eclipse.update.ui</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.update</groupId>
-                    <artifactId>org.eclipse.update.configurator</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.update</groupId>
-                    <artifactId>org.eclipse.update.core</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.help</groupId>
-                    <artifactId>org.eclipse.help</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.equinox</groupId>
-                    <artifactId>org.eclipse.equinox.registry</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.equinox</groupId>
-                    <artifactId>org.eclipse.equinox.preferences</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.runtime.compatibility</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.core</groupId>
-                    <artifactId>org.eclipse.core.runtime.compatibility.auth</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.ant</groupId>
-                    <artifactId>org.eclipse.ant.core</artifactId>
-                </exclusion>
-            </exclusions>
-        </dependency>
-        <dependency>
-            <groupId>org.eclipse.swt</groupId>
-            <artifactId>org.eclipse.swt</artifactId>
+            <artifactId>runtime</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.osgi</groupId>
-            <artifactId>org.eclipse.osgi</artifactId>
+            <groupId>org.eclipse</groupId>
+            <artifactId>swt</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.swt</groupId>
-            <artifactId>org.eclipse.swt.win32.win32.x86</artifactId>
+            <groupId>org.eclipse</groupId>
+            <artifactId>osgi</artifactId>
+        </dependency>
+        <dependency>
+            <groupId>org.eclipse.swt.win32.win32</groupId>
+            <artifactId>x86</artifactId>
         </dependency>
         <dependency>
             <groupId>org.eclipse.ui</groupId>
-            <artifactId>org.eclipse.ui.ide</artifactId>
-            <exclusions>
-                <exclusion>
-                    <groupId>org.eclipse.ui</groupId>
-                    <artifactId>org.eclipse.ui.forms</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>org.eclipse.ui</groupId>
-                    <artifactId>org.eclipse.ui.views</artifactId>
-                </exclusion>
-            </exclusions>
+            <artifactId>ide</artifactId>
         </dependency>
         <dependency>
-            <groupId>org.eclipse.jface</groupId>
-            <artifactId>org.eclipse.jface</artifactId>
+            <groupId>org.eclipse</groupId>
+            <artifactId>jface</artifactId>
         </dependency>
         <dependency>
             <groupId>org.apache.ant</groupId>
@@ -230,7 +162,7 @@
                     <manifestLocation>META-INF</manifestLocation>
                     <instructions>
                         <!-- Embed all dependencies, except those which are provided by
the Eclipse runtime -->
-                        <Embed-Dependency>*;scope=compile|runtime;artifactId=!org.eclipse.*|commons-logging|wstx-asl|geronimo-activation_1.1_spec|geronimo-javamail_1.4_spec|geronimo-stax-api_1.0_spec|ant*</Embed-Dependency>
+                        <Embed-Dependency>*;scope=compile|runtime;groupId=!org.eclipse.*;artifactId=!commons-logging|wstx-asl|geronimo-activation_1.1_spec|geronimo-javamail_1.4_spec|geronimo-stax-api_1.0_spec|ant*</Embed-Dependency>
                         <Embed-Directory>lib</Embed-Directory>
                         <Embed-Transitive>true</Embed-Transitive>
                         <!-- Exclude imports that are actually not used -->



Mime
View raw message