axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GIACAMOND" <jean-m...@giacamond.com>
Subject AXIS2C Rest behavior
Date Fri, 01 Mar 2013 12:40:11 GMT
Hello,

 

I'm implementing a solution under AXIS2C 1.7.0, and I had to make a small
correction to :  http_sender.c module to send correctly pure "rest" query
(no soap).  The problem was that the query string was not sent.

 

My code is in RED bellow.

 

Thank a lot for what you guys did J.

 

Best regards,

 

Jean-Marc

 

I have change the following line of codes:

 

More or Less line 650.

 

        /* Processing HTTP GET, HEAD and DELETE */

 

        axis2_char_t *request_params = NULL;

        axis2_char_t *path = NULL;

 

        request_params = axis2_http_sender_get_param_string(sender, env,
msg_ctx);

 

        if(request_params)

        {

            /* substituting AXIS2_Q_MARK for "?" */

            path = axutil_strcat(env, axutil_url_get_path(url, env),
AXIS2_Q_MARK_STR,

                request_params, NULL);

            AXIS2_FREE(env->allocator, request_params);

            request_params = NULL;

        }

        else

        {

            /* JML Begin */

            /* path = axutil_strdup(env, axutil_url_get_path(url, env)); */

            path = axutil_strcat(env, axutil_url_get_path(url, env),

                axutil_url_get_query(url, env), NULL);

            /* JML End */

        }

 

 

 


Mime
View raw message