axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kopparapu, Sangeeta (GE Healthcare, consultant)" <Sangeeta.Koppar...@ge.com>
Subject RE: Linker errors when trying to build from AXIS2C source
Date Thu, 22 Dec 2011 15:32:49 GMT
Am not able to build from Axis2c-1.7.0-RC4 also. When I run ./configure
(with/without prefix parameter), below errors are thrown at the command
line:

 

config.status: creating src/modules/mod_addr/Makefile

config.status: creating src/modules/mod_log/Makefile

config.status: error: cannot find input file: `test/Makefile.in'

 

 

Thanks & Regards, 
Sangeeta G Kopparapu. 

From: Kopparapu, Sangeeta (GE Healthcare, consultant) 
Sent: Thursday, December 22, 2011 9:02 AM
To: Apache AXIS C User List
Subject: RE: Linker errors when trying to build from AXIS2C source

 

Thank you and again sorry to urge you guys. Without debugging I could
not proceed further. 

 

Thanks & Regards, 
Sangeeta G Kopparapu. 

From: Dinesh Weerapurage [mailto:xydinesh@gmail.com] 
Sent: Wednesday, December 21, 2011 11:31 PM
To: Apache AXIS C User List
Subject: Re: Linker errors when trying to build from AXIS2C source

 

Could you please try RC4, even though it is been a while we have posted
RC4. It is the latest(except svn trunk). 

 

http://people.apache.org/~samisa/axis2c-1.7.0-RC4/ 

 

I'm not having internet connection as I used to , so it will be while
before Ill check email again :) 

 

thanks,

Dinesh.

 

On Thu, Dec 22, 2011 at 4:22 AM, Kopparapu, Sangeeta (GE Healthcare,
consultant) <Sangeeta.Kopparapu@ge.com> wrote:

I am sorry urge you. But could somebody help me here? 

 

Thanks & Regards, 
Sangeeta. 

From: Kopparapu, Sangeeta (GE Healthcare, consultant) 
Sent: Tuesday, December 20, 2011 6:12 PM
To: Apache AXIS C User List
Subject: RE: Linker errors when trying to build from AXIS2C source

 

Hi, am still not able to build libraries from source code downloaded
from below location. This time, I failed in first step itself:

 

./configure -prefix=<path to axis2c home>

config.status: error: cannot find input file:
`src/core/transport/http/sender/ntlm/Makefile.in'

 

I am trying to build axis2c binaries from source on OpenSUSE linux 64bit
machine.  Please help. 

 

Thanks & Regards, 
Sangeeta G Kopparapu. 

From: Samisa Abeysinghe [mailto:samisa.abeysinghe@gmail.com] 
Sent: Tuesday, August 30, 2011 5:26 PM
To: Apache AXIS C User List
Subject: Re: Linker errors when trying to build from AXIS2C source

 

I will have a look at this. 

 

Few people have reported problems on Suse OS. 

 

I think this is mainly due to compiler version and how it behaves. Note
that, most of us use Ubuntu like Linux flavors. 

 

Please try the RC3 of 1.7.0 in the mean time, to see if the problem is
gone away. http://people.apache.org/~samisa/axis2c-1.7.0-RC3/

Samisa Abeysinghe

http://samisa-abeysinghe.blogspot.com/

On Mon, Aug 29, 2011 at 11:31 PM, Kopparapu, Sangeeta (GE Healthcare,
consultant) <Sangeeta.Kopparapu@ge.com> wrote:

Hi,

 

I am trying to build APACHE AXIS2C source on OpenSUSE Linux 64-bit
machine. I am following the steps given on:
http://axis.apache.org/axis2/c/core/docs/installationguide.html#1_3_1,
but I am getting undefined reference errors as shown below:.

 

 

gcc-4.1 -g -pthread -g -O2 -D_LARGEFILE64_SOURCE -ansi -Wall -Werror
-Wno-implicit-function-declaration -g -D_GNU_SOURCE
-DAXIS2_GUTHTHILA_ENABLED -DAXIS2_SVR_MULTI_THREADED -o
axis2_http_server http_server_main.o
../../../../../../src/core/transport/http/util/.libs/libaxis2_http_util.
a
../../../../../../src/core/transport/http/common/.libs/libaxis2_http_com
mon.a ../../../../../../axiom/src/om/.libs/libaxis2_axiom.a
../../../../../../util/src/.libs/libaxutil.a
../../../../../../axiom/src/parser/guththila/.libs/libaxis2_parser.a
../../../../../../src/core/description/.libs/libaxis2_description.a
../../../../../../src/core/deployment/.libs/libaxis2_deployment.a
../../../../../../src/core/context/.libs/libaxis2_context.a
../../../../../../src/core/clientapi/.libs/libaxis2_clientapi.a
../../../../../../src/core/engine/.libs/libaxis2_engine.a
../../../../../../src/core/transport/http/sender/.libs/libaxis2_http_sen
der.a
../../../../../../src/core/transport/http/receiver/.libs/libaxis2_http_r
eceiver.a
/home/{user}/axis2c-src-1.6.0/src/core/engine/.libs/libaxis2_engine.a
/home/{user}/axis2c-src-1.6.0/neethi/src/.libs/libneethi.a
/home/{user}/axis2c-src-1.6.0/src/core/transport/http/common/.libs/libax
is2_http_common.a ../../../../../../neethi/src/.libs/libneethi.a
/home/{user}/axis2c-src-1.6.0/axiom/src/om/.libs/libaxis2_axiom.a
/home/{user}/axis2c-src-1.6.0/axiom/src/parser/guththila/.libs/libaxis2_
parser.a
/home/{user}/axis2c-src-1.6.0/guththila/src/.libs/libguththila.a
/home/{user}/axis2c-src-1.6.0/util/src/.libs/libaxutil.a -lpthread -lz
-ldl

/home/{user}/axis2c-src-1.6.0/src/core/engine/.libs/libaxis2_engine.a(de
sc_builder.o): In function `axis2_desc_builder_load_default_msg_recv':

/home/{user}/axis2c-src-1.6.0/src/core/deployment/desc_builder.c:1070:
undefined reference to `axis2_raw_xml_in_out_msg_recv_create'

collect2: ld returned 1 exit status

make[8]: *** [axis2_http_server] Error 1

make[8]: Leaving directory
`/home/{user}/axis2c-src-1.6.0/src/core/transport/http/server/simple_axi
s2_server'

make[7]: *** [all-recursive] Error 1

make[7]: Leaving directory
`/home/{user}/axis2c-src-1.6.0/src/core/transport/http/server/simple_axi
s2_server'

make[6]: *** [all-recursive] Error 1

make[6]: Leaving directory
`/home/{user}/axis2c-src-1.6.0/src/core/transport/http/server'

make[5]: *** [all-recursive] Error 1

make[5]: Leaving directory
`/home/{user}/axis2c-src-1.6.0/src/core/transport/http'

make[4]: *** [all-recursive] Error 1

make[4]: Leaving directory
`/home/{user}/axis2c-src-1.6.0/src/core/transport'

make[3]: *** [all-recursive] Error 1

make[3]: Leaving directory `/home/{user}/axis2c-src-1.6.0/src/core'

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/home/{user}/axis2c-src-1.6.0/src'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/{user}/axis2c-src-1.6.0'

make: *** [all] Error 2

 

 

 

In brief, 

 

Step 1:  ./configure --prefix=${AXIS2C_HOME} ==> success

Step 2:  make  ==> FAIL. error is:
/home/koppasa/axis2c-src-1.6.0/src/core/deployment/desc_builder.c:1070:
undefined reference to `axis2_raw_xml_in_out_msg_recv_create'

 

Please let me know what steps that I need to follow to resolve those
linker errrors if anybody had already experienced this kind of error(s).

 

 

Thanks & Regards, 
Sangeeta G Kopparapu. 

 

 


Mime
View raw message