axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stadelmann Josef" <josef.stadelm...@axa-winterthur.ch>
Subject AW: Can Axis2c work in IPv6 env?
Date Tue, 21 Jun 2011 07:32:33 GMT
Why not making the same client as axis2/Java client, 

and if that works then you know that your TCPIP Stack using only the
IPv6 protocol works 

when told to work by the axis2/J transport_sender and axis2/J
transport_receiver.

but fails when told to work by the axis2/C transport_sender or
transport_receiver.

Again - one for Wireshark which can show you exceptions on a level axis2
can't.

I've found once checksum errors caused by hardware, switching checksum
calculation

by hardware off and enabling it by software was a workaround unless
network HW was

Changed.

Josef

 

Von: preet $ [mailto:preet3039@gmail.com] 
Gesendet: Montag, 20. Juni 2011 22:45
An: Apache AXIS C User List
Betreff: Re: Can Axis2c work in IPv6 env?

 

Hello

 

    Some more info...The axis log has the following lines

 

[Mon Jun 20 09:58:02 2011] [debug]
..\..\src\core\transport\http\sender\http_transport_sender.c(246)
ctx_epr:http://::1:8080/test/services/testService
[Mon Jun 20 09:58:02 2011] [debug]
..\..\src\core\transport\http\sender\http_transport_sender.c(805) using
axis2 native http sender.
[Mon Jun 20 09:58:02 2011] [debug]
..\..\src\core\transport\http\sender\http_sender.c(416)
msg_ctx_id:urn:uuid:367381f6-823a-4436-96ce-42a3c98079b1
[Mon Jun 20 09:58:03 2011] [error]
..\..\src\core\transport\http\sender\http_client.c(238) Error creating a
socket. Most probably error returned by OS
[Mon Jun 20 09:58:03 2011] [error]
..\..\src\core\transport\http\sender\http_client.c(239) Socket Creation
failed.
[Mon Jun 20 09:58:03 2011] [error]
..\..\src\core\transport\http\sender\http_client.c(544) client data
stream  null or socket error for host  and 80 port
[Mon Jun 20 09:58:03 2011] [error]
..\..\src\core\transport\http\sender\http_client.c(548) A read
attempt(HTTP) for the reply without sending the request
[Mon Jun 20 09:58:03 2011] [error]
..\..\src\core\transport\http\sender\http_sender.c(1381) status_code < 0
[Mon Jun 20 09:58:03 2011] [error] ..\..\src\core\engine\engine.c(179)
Transport sender invoke failed

I tried with various types of IPv6 ::1, [::1], 0:0:0:0:0:0:0:1 but from
the above message it looks like it is not taking the host and port
correctly. Did anyone get the same result.  Is there a work around.

 

Thanks

Preet

 

On Mon, Jun 20, 2011 at 12:07 PM, preet $ <preet3039@gmail.com> wrote:

Hello,

 

     I am using Axis2c1.6 and wanted to know if it works with IPv6. I
see some responses that says it does not. Please find the installation
scenario... 

 

 I have a windows 7 and it has dual stack. I have my webservices server
running on JBoss. I started JBoss with -b ipv6 address and I see the
port 8080 bound to ::1 address. I am able to see the WSDL from my
browser. So the server is successfully bound to IPv6. The webservices
server is implemented in Axis java. 

 

The client is a standalone and it uses Axis2c. The application log on
the client side says it was able to get the stub and call the request
and get a response. Does this mean it was able to make a connection? 

The response comes out to be null and the error I get is error code is
75 and the error message is "A read attempt(HTTP) for the reply without
sending the request".

 

Am I doing anything wrong, is there any change I need to do to get it to
work

 

Thanks in advance

Preet

 


Mime
View raw message