axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stadelmann Josef" <josef.stadelm...@axa-winterthur.ch>
Subject AW: AW: HTTPS/SSL with proxy server doesn't work
Date Tue, 01 Mar 2011 08:01:51 GMT
Hi Frank,

What OS is your service running at?

For me the question is: How far does the request travel from the client
to the server using https? 

Does it pass the port on which your Application Server is listening for
the https request?

That to know would be good. 

Do we have a way off logging this arrival of a https/tcpip network
package?

I think a network monitor such as Wireshark could help here, but only if
you can run it at the server?

Otherwhise you have to seek for a different network monitor and dump log
traffic in a trace file.

I run sometimes a tcpdumper at the open vms server machine and then 

I can see any package arriving and leaving, and I write this all into a
trace file.

Then I move the trace to the PC and using Wireshark I can open it and
see what has happen.

If no https package arrives at the server that would get us further.

If it arrives we are also further and would then have to find out about
the response the server makes toward the wire

Josef

 

Von: Gordon Brown [mailto:gordonw.brown@yahoo.com] 
Gesendet: Montag, 28. Februar 2011 19:52
An: Apache AXIS C User List
Betreff: Re: AW: HTTPS/SSL with proxy server doesn't work

 

My browser in the same machine that I ran web service client works fine.
I used the same proxy server setting in my web service client and the
browser.

 

Thanks!
Frank  

 

________________________________

From: Stadelmann Josef <josef.stadelmann@axa-winterthur.ch>
To: Apache AXIS C User List <c-user@axis.apache.org>
Sent: Mon, February 28, 2011 3:20:09 AM
Subject: AW: HTTPS/SSL with proxy server doesn't work




Did you ever use Wireshark to monitor the protocol between your client
and the firewall or between your server and the firewall? Is any other
traffic  HTTPS i.e. from a browser to a remote server via HTTPS and
PROXY working? (this to assure that the firewall can handle/forward
HTTPS protocol requests properly). Is it really the case that each
segment in your network topology is capable to support HTTPS?

 

Josef

 

Von: Gordon Brown [mailto:gordonw.brown@yahoo.com] 
Gesendet: Donnerstag, 24. Februar 2011 23:14
An: c-dev@axis.apache.org
Cc: c-user@axis.apache.org
Betreff: HTTPS/SSL with proxy server doesn't work

 

   Hi All, 

 

I am using axis2/c 1.5 for a web service client application and
encountering a problem when communicating with a web service server
through HTTPS/SSL. My client is behind a proxy server and I also have
the right to configure the web service server. I tested that if there is
no proxy server involved, HTTPS/SSL communication is fine for me (after
properly configure the certificates ce tera), I tested regular
communication (simple HTTP/SOAP instead of HTTPS/SSL) WITH the proxy
server, it is also fine. Only when I use HTTPS/SSL together with proxy
server I got the problem. 

 

I searched the jira bug repository, and it seems that someone else
reported the same issue a while ago
(https://issues.apache.org/jira/browse/AXIS2C-1397).

 

My questions are:

 

(1) Is this really a bug? Or something I didn't configure properly?

 

(2) If this is a bug, is there a fix or workaround?

 

Thanks!
Gordon 

 

 


Mime
View raw message