axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Saju Nair" <s...@tanmic.co.in>
Subject RE: AXIS2C Installation on Windows
Date Tue, 29 Mar 2011 10:12:34 GMT
Hi All Developers

Sorry, forgot to add the log entries

 

 

 

 

From: Saju Nair [mailto:saju@tanmic.co.in] 
Sent: 29 March 2011 15:37
To: 'Dumindu Pallewela'
Cc: 'Apache AXIS C User List'
Subject: RE: AXIS2C Installation on Windows

 

Hi Dumindu,

Thanks for your response. 

- Apache Installation:

   I am able to goto http://localhost

   and see the message “It works” – indicating the the Apache install works ok.

 

- Axis2/C Installation:

   I used the AXIS2/C binary install, and copied over the

   AXIS2C_HOME/lib/mod_axis2c.dll to the 

   APACHE_BIN_DIR/modules/

 

   httpd.conf, has following entries:

##------------------------------------------------------

LoadModule axis2_module modules/mod_axis2.dll

Axis2RepoPath D:/saju/tools/Apache/axis2c-bin-1.6.0-win32

Axis2LogFile D:/saju/tools/Apache/logs/axis2.log

Axis2MaxLogFileSize 10

Axis2LogLevel trace

<Location /axis2>

SetHandler axis2_module

</Location>

##-------------------------------------------------------

 

   Now, when I try to goto http://localhost/axis2/services, get an error

   HTTP404 – Webpage cannot be found.

 

 

 

APACHE_BIN_DIR/logs

error.log

Starting the Apache2.2 service

The Apache2.2 service is running.

rmine the server's fully qualified domain name, using aaa.bbb.ccc.ddd for ServerName

[Tue Mar 29 15:27:19 2011] [notice] Apache/2.2.17 (Win32) configured -- resuming normal operations

[Tue Mar 29 15:27:19 2011] [notice] Server built: Oct 18 2010 01:58:12

[Tue Mar 29 15:27:19 2011] [notice] Parent: Created child process 7680

httpd.exe: Could not reliably determine the server's fully qualified domain name, using aaa.bbb.ccc.ddd
for ServerName

httpd.exe: Could not reliably determine the server's fully qualified domain name, using aaa.bbb.ccc.ddd
for ServerName

[Tue Mar 29 15:27:19 2011] [notice] Child 7680: Child process is running

[Tue Mar 29 15:27:19 2011] [notice] Child 7680: Acquired the start mutex.

[Tue Mar 29 15:27:19 2011] [notice] Child 7680: Starting 64 worker threads.

[Tue Mar 29 15:27:19 2011] [notice] Child 7680: Starting thread to listen on port 80.

[Tue Mar 29 15:28:02 2011] [error] [client 127.0.0.1] File does not exist: C:/Program Files/Apache
Software Foundation/Apache2.2/htdocs/axis2

[Tue Mar 29 15:34:04 2011] [error] [client 127.0.0.1] File does not exist: C:/Program Files/Apache
Software Foundation/Apache2.2/htdocs/axis2, referer: http://axis.apache.org/axis2/c/core/docs/installationguide.html

 

access.log

127.0.0.1 - - [29/Mar/2011:15:24:33 +0530] "GET / HTTP/1.1" 304 -

127.0.0.1 - - [29/Mar/2011:15:24:38 +0530] "GET /axis2/services HTTP/1.1" 404 212

127.0.0.1 - - [29/Mar/2011:15:24:42 +0530] "GET /axis2/services HTTP/1.1" 404 212

127.0.0.1 - - [29/Mar/2011:15:28:02 +0530] "GET /axis2/services HTTP/1.1" 404 212

 

 

Regards,

- Saju. 

 

 

From: Dumindu Pallewela [mailto:pallewela@gmail.com] 
Sent: 23 March 2011 10:00
To: Saju Nair
Cc: Apache AXIS C User List
Subject: Re: AXIS2C Installation on Windows

 

 

On Mon, Mar 21, 2011 at 4:36 PM, Saju Nair <saju@tanmic.co.in> wrote:

Hi Dumindu,

Thanks for your response.

 

1, On using the downloaded binaries,

Thanks. I had originally copied the 

AXIS2C_INSTALL/lib/mod_axis2.dll -> APACHE_INSTALL_DIR/modules/mod_axis2.so

based on the instructions in http://axis.apache.org/axis2/c/core/docs/installationguide.html#3_2

 

I reinstalled Apache2.2 and 

I did as you indicated, and copied the mod_axis2.dll as .dll itself.

Added the loadModule in the httpd.conf.

 

Now, when I start Apache, the UI indicates that the Service is running,

I get a message though, in the APACHE_INSTALL_DIR/logs/error.log

Starting the Apache2.2 service

The Apache2.2 service is running.

rmine the server's fully qualified domain name, using aaa.bbb.cc.dd for ServerName

[Mon Mar 21 14:16:52 2011] [notice] Apache/2.2.17 (Win32) configured -- resuming normal operations

[Mon Mar 21 14:16:52 2011] [notice] Server built: Oct 18 2010 01:58:12

[Mon Mar 21 14:16:52 2011] [notice] Parent: Created child process 7312

httpd.exe: Could not reliably determine the server's fully qualified domain name, using aaa.bbb.cc.dd
for ServerName

httpd.exe: Could not reliably determine the server's fully qualified domain name, using aaa.bbb.cc.dd
for ServerName

[Mon Mar 21 14:16:52 2011] [notice] Child 7312: Child process is running

[Mon Mar 21 14:16:52 2011] [notice] Child 7312: Acquired the start mutex.

[Mon Mar 21 14:16:52 2011] [notice] Child 7312: Starting 64 worker threads.

[Mon Mar 21 14:16:52 2011] [notice] Child 7312: Starting thread to listen on port 80.

 

even though, the httpd.conf contains

ServerName localhost

 

this looks to me like an apache configuration issue than anything to do with axis2/c.

 

 

 

2, On the path of compiling the source distribution, 

I added the path to APACHE_INSTALL_DIR/include during the compile.

Now, the compile complains about apr.h, which is located in APACHE_INSTALL_DIR/srclib/apr/include

but, the compile continues to complain. 

 

 

you also need to provide the path to apr.h in your include path.

 

/dumindu. 


Mime
View raw message