axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emanuele Benedetti" <be...@mclink.it>
Subject Error in sending routine
Date Sat, 05 Feb 2011 08:46:09 GMT
Hi

I found a bug (or it appears a bug to me) in  
axis2_svc_client_send_receive().

If it fails to send a message, it try to read the response anyway. The  
result is the the error message returned by AXIS2_ERROR_GET_MESSAGE(  
m_env->error ) is:

A read attempt(HTTP) for the reply without sending the request

while, in reality was:

Error creating a socket. Most probably error returned by OS

like can be seen in the axis2 log:


[Sat Feb  5 09:12:54 2011] [error] http_client.c(238) Error creating a  
socket. Most probably error returned by OS
[Sat Feb  5 09:12:54 2011] [error] http_client.c(239) Socket Creation  
failed.
[Sat Feb  5 09:12:54 2011] [error] http_client.c(544) client data stream   
null or socket error for host cis.porezna-uprava.hr and 8443 port
[Sat Feb  5 09:12:54 2011] [error] http_client.c(548) A read attempt(HTTP)  
for the reply without sending the request
[Sat Feb  5 09:12:54 2011] [error] http_sender.c(1381) status_code < 0
[Sat Feb  5 09:12:54 2011] [error] engine.c(179) Transport sender invoke  
failed

It is not a serious bug, but it generates confusion.



-- 
Saluti
Emanuele

---------------------------------------------------------------------
To unsubscribe, e-mail: c-user-unsubscribe@axis.apache.org
For additional commands, e-mail: c-user-help@axis.apache.org


Mime
View raw message