axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stadelmann Josef" <josef.stadelm...@axa-winterthur.ch>
Subject AW: http basic authentication
Date Tue, 11 Jan 2011 08:32:00 GMT
Mabey this helps; but say thanks to Mr. or Ms. Sihem

I know it is for the server, but maybe a hint about the approach to use.
Josef


Hello!
finally I found some documentations about HTTP authentication which seems to be easy to set
up. I modified the axis2.xml file as followed:
<transportSender name="http" class="axis2_http_sender">
        <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
        <parameter name="xml-declaration" insert="false"/>      
        <parameter name="HTTP-Authentication" username="sihem" password="sihem" locked="true"/>
    </transportSender>

and I use the echo_blocking_auth application (located in axis2c-src-1.5.0/samples/user_guide/clients)

But the function axis2_svc_client_get_http_auth_required(svc_client, env) returns false which
indicates that the server does not wait for credentials.
So is there something else to configure ?
Thanks by advance
sihem

-----Urspr√ľngliche Nachricht-----
Von: Adam Edgar [mailto:aedgar@research.att.com] 
Gesendet: Montag, 10. Januar 2011 22:41
An: Apache AXIS C User List
Betreff: http basic authentication

I am writing a client using axis2c and trying to connect to a webserver
that requires the POST command "Authorization: Basic" a la
http://en.wikipedia.org/wiki/Basic_access_authentication . Is there a
simple way to inform the http transfer layer to use a given
username/password combination for this?

Thanks much,

ASE


---------------------------------------------------------------------
To unsubscribe, e-mail: c-user-unsubscribe@axis.apache.org
For additional commands, e-mail: c-user-help@axis.apache.org

Mime
View raw message