axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Baier <thomas.ba...@gmx.net>
Subject Re: AXIS2C on VISTA / VS9 and DLL Dependencies
Date Thu, 24 Jun 2010 05:33:14 GMT
The main question is why the binaries require MSVCR80D.dll. This is the
debug version of the CRT and should not be referenced in a release
build. It is normally only part of the compiler and should not be part
of any runtime packages. Which of the Axis2C binaries shows this
dependency? You can check this easily with dependency walker.

Best,
Thomas

Danushka Menikkumbura schrieb:
> Josef does not have MSVCR80D.dll on his machine at all.
> 
> Danushka
> 
> On Thu, Jun 24, 2010 at 10:36 AM, Nandika Jayawardana
> <jayawark@gmail.com <mailto:jayawark@gmail.com>> wrote:
> 
>     Most probably, this is due to you having another axis2/c binary
>     which is added to your path environment variable.
> 
>     Regards
>     Nandika
> 
> 
> 
>     On Wed, Jun 23, 2010 at 2:21 PM, Stadelmann Josef
>     <josef.stadelmann@axa-winterthur.ch
>     <mailto:josef.stadelmann@axa-winterthur.ch>> wrote:
> 
>         Hi all,
> 
>         I wonder If one can tell me what is wrong;
> 
>         Checked out ZLIB, LIBXML2, AXIS”C sources and I have build all
>         error free using nmake and visual studio 2008 on a Vista System
>         (SP1)
> 
>         I have read the %axis2c_home%\build\deploy\INSTALL manual
> 
>         (thank you for this very valuable information in this manual)
> 
> 
>         Now, when I try to launch axis2_http_server.exe I get
> 
>         Picture (Device Independent Bitmap)
> 
>         When I look on my Vista System which has among many thing i.e.
>         Visual Studio 2008 Team Suite installed, as well as Office etc.
>         then ….
> 
>         I cannot find at all the MSVCR80D.dll but many of the
>         MSVCR90D.dll’s (a newer version) OR older versions such as
>         MSVCR70D.dll
> 
>         What is wrong with my setup? OR Why do I miss MSVCR80D.dll?
> 
>         At the moment I try to figure out using the Dependency Walker
>         which other DLL?s are missing or can’t be located. And for
>         axis2_http_server.exe, there are quite a lot; in example
>         Dependency walker cannot locate MSVCR90D.dll which is on my
>         system. I guess this DLL is correctly registered because I do
>         not assume / think that other tools will work without this
>         important central DLL.
> 
> 
> 
>         *** and maybe one can give me a hint how to debug native code
>         (ANSI C code is compiled into native code only using VS2009),
> 
>         I managed to do so at VS/VC 6.0 times but guess, due to this
>         missing DLL’s etc. I have no lucle to do so.), Further I had no
>         difficulty to compile and build (to make) using VS2003 all of
>         AXIS2C including LIBXML2 and ZLIB below, and I was at all times
>         able to debug test and dig down into axutil code or libxml2
>         code, but today with VS2008 I feel like amateur!, How can I dig
>         down into underlying libs; or do I have to go back to VS2003 or
>         even VS6.0? away from my VS2008TS ***
> 
> 
>         How shall I proceed?
> 
>         Any ideas welcome!
> 
>         Regards and Thanks
> 
>         Josef.Stadelmann
> 
> 
> 
> 
>     -- 
>     http://nandikajayawardana.blogspot.com/
>     WSO2 Inc: http://www.wso2.com
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: c-user-unsubscribe@axis.apache.org
For additional commands, e-mail: c-user-help@axis.apache.org


Mime
View raw message