axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <sam...@wso2.com>
Subject Re: Axis2c and openssl 1.0
Date Sat, 15 May 2010 03:04:36 GMT
On Sat, May 15, 2010 at 2:29 AM, Steve Leland <steve@pouchapond.com> wrote:

> Our product runs on a Win2008 R2 server, and is built on top of Axis2c 1.6
> and OpenSSL 0.9.8l - many thanks for the good work!
>
> I am chasing a memory leak that only occurs for our ssl requests, and
> thought I might get lucky and find it already fixed in OpenSSL 1.0.0.
>
> If I use the 1.6 makefile, Axis2c 1.6 compiles and links with OpenSSL 1.0
> but dies on startup with memory corruption.  If I use the makefile currently
> on the trunk to build Axis2c 1.6 and OpenSSL 1.0, the compile fails in
> core\transport\http\sender\ssl_utils.c.
>

What are the errors?

>
> Would you expect that Axis2c 1.6 should work with OpenSSL 1.0?
>

We have not tried yet. But I hope we can make it to work.


>
> Using the Axis2c source tree I just pulled down from the trunk, I built
> Axis2c with OpenSSL 1.0, then regenerated the C code from our wsdl using
> wsdl2c.bat.  The result won't compile - it's looking for
> axiom_element_declare_namespace_assume_param_ownership(), which is in
> axiom_element.h but #ifdefd out.  I don't know if it matters, but it's using
> the Axis2 1.5.1 jars in the codegen step.
>

What command line options did you use to codegen?

Can you share the WSDL?

Samisa...


>
> Is there something new I need to do to get the new codegen to work?
>
> Thanks!
> Steve
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: c-user-unsubscribe@axis.apache.org
> For additional commands, e-mail: c-user-help@axis.apache.org
>
> --
Samisa Abeysinghe
Director, Engineering - WSO2 Inc.

http://wso2.com/ - "lean . enterprise . middleware"

Mime
View raw message