axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 卢杨 <lylyl...@hotmail.com>
Subject Re: [Axis2]Can't run axis2c on apache
Date Thu, 29 Apr 2010 23:55:58 GMT

Dear Developers,

Yes in axis2.log it prints:
[Fri Apr 30 07:53:11 2010] [debug] ..\..\src\core\transport\http\server\apache2\apache2_worker.c(238)
http://localhost/axis2/web_services
[Fri Apr 30 07:53:11 2010] [debug] ..\..\src\core\transport\http\server\apache2\apache2_worker.c(280)
Client HTTP version HTTP/1.1
[Fri Apr 30 07:53:11 2010] [debug] ..\..\src\core\engine\rest_disp.c(114) Checking for service
using target endpoint address : http://localhost/axis2/web_services
[Fri Apr 30 07:53:11 2010] [error] ..\..\src\core\transport\http\util\http_transport_utils.c(2557)
Service or operation not found

But  error.log shows nothing but 
[Fri Apr 30 07:40:50 2010] [warn] pid file E:/Apache2.2/logs/httpd.pid overwritten -- Unclean
shutdown of previous Apache run?
[Fri Apr 30 07:40:50 2010] [notice] Apache/2.2.15 (Win32) Axis2C/1.6.0 configured -- resuming
normal operations
[Fri Apr 30 07:40:50 2010] [notice] Server built: Mar  4 2010 11:27:46
[Fri Apr 30 07:40:50 2010] [notice] Parent: Created child process 1760
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.32.1
for ServerName
httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.32.1
for ServerName
[Fri Apr 30 07:40:50 2010] [notice] Child 1760: Child process is running
[Fri Apr 30 07:40:51 2010] [notice] Child 1760: Acquired the start mutex.
[Fri Apr 30 07:40:51 2010] [notice] Child 1760: Starting 64 worker threads.
[Fri Apr 30 07:40:51 2010] [notice] Child 1760: Starting thread to listen on port 80.

Where is the problem?

Yours sincerely,
Jason




From: Samisa Abeysinghe 
Sent: Friday, April 30, 2010 7:30 AM
To: Apache AXIS C User List 
Subject: Re: [Axis2]Can't run axis2c on apache





On Thu, Apr 29, 2010 at 8:42 PM, ¬�� <lylylytc@hotmail.com> wrote:

  Dear Sam,

  I have found out what problem I have. I can run the server without using the prefix defined
by me. I don't know why.


Does it log an error?  
  And I meet another problem that I don't know how to create a web page to call the axis2c
client which is a exe file generated by C. Can you help me?


Why not use PHP ?
http://wso2.org/project/wsf/php/2.0.0/docs/index.html


Samisa... 

  Yours sincerely,
  Jason


  From: Sam Carleton 
  Sent: Thursday, April 29, 2010 11:00 PM
  To: Apache AXIS C User List 
  Subject: Re: [Axis2]Can't run axis2c on apache


  Jason,

  You are running on Windows correct?  When I first got things up and running, there are a
few DLL's I needed to place in the path.  I opted placed them in the apache\bin folder, I
think they where the guththila.dll and something else, if you run depends on the mod_axis2,
it should let you know which ones are missing.

  Sam


  2010/4/29 ¬�� <lylylytc@hotmail.com>

    Dear Developers,

    When I run the apache and enter http://localhost/axis2/web_services. It can't find a page.
In axis2.log it shows me:

    [Thu Apr 29 11:59:36 2010] [debug] ..\..\src\core\transport\http\server\apache2\apache2_worker.c(238)
http://localhost/axis2/web_services
    [Thu Apr 29 11:59:36 2010] [debug] ..\..\src\core\transport\http\server\apache2\apache2_worker.c(280)
Client HTTP version HTTP/1.1
    [Thu Apr 29 11:59:36 2010] [debug] ..\..\src\core\engine\rest_disp.c(114) Checking for
service using target endpoint address : http://localhost/axis2/web_services
    [Thu Apr 29 11:59:36 2010] [error] ..\..\src\core\transport\http\util\http_transport_utils.c(2557)
Service or operation not found

    How can I do?

    Yours sincerely,
    Jason


-- 
Samisa Abeysinghe 
Director, Engineering - WSO2 Inc.

http://wso2.com/ - "lean . enterprise . middleware"


Mime
View raw message