axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nandika Jayawardana <jayaw...@gmail.com>
Subject Re: Data element of the OM Node is NULL
Date Tue, 26 Jan 2010 12:03:58 GMT
Can you attach the code which construct the response in your service ?

Regards
Nandika

On Mon, Jan 25, 2010 at 9:47 AM, Sam Carleton <scarleton@miltonstreet.com>wrote:

> When I run Apache Server and Axis2/C in development, all is well, when I
> run it in a clean VM, I am getting the error:
>
> Data element of the OM Node is NULL
>
> What exactly is this telling me?  It is saying that my service is not
> building the response object or that the value being passed in is NULL?  The
> service is written in such a way that the nodeId can be null/empty string.
>  Oh the client is .Net 3.5
> ----------------------------------
> Where is the request message:
>
> <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
>    <s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema">
>       <getNode xmlns="urn:mmpp:catalogmgr">
>          <nodeId xmlns=""/>
>          <ignoreActiveFlag xmlns="">true</ignoreActiveFlag>
>       </getNode>
>    </s:Body>
> </s:Envelope>
> ----------------------------------
> Here is the reply:
>
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
> ">
>   <soapenv:Body>
>  <soapenv:Fault>
> <faultcode>soapenv:Sender</faultcode>
>  <faultstring>Data element of the OM Node is NULL</faultstring>
> <detail>
>    <fault>CatalogMgr|urn:mmpp:catalogmgr failed</fault>
> </detail>
>  </soapenv:Fault>
>   </soapenv:Body>
> </soapenv:Envelope>
>



-- 
http://nandikajayawardana.blogspot.com/
WSO2 Inc: http://www.wso2.com

Mime
View raw message