axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Carleton <scarle...@gmail.com>
Subject Re: .Net client can call Axis2/C service, Axis2/C client cannot
Date Sat, 12 Dec 2009 16:05:43 GMT
Selvaratnam,

Thank you for your help!!!!  I was assuming the issue was related to the
header in the request..  Here is the TCPMon log for the Axis2/C client to
Axis2/C service that does not work:

########## *************** BEGIN *************** ##########

  POST /axis2/services/parataMgr HTTP/1.1
  User-Agent: Axis2C/1.6.0
  SOAPAction: "urn:mmpp:parataMgr/getVersionCheck"
  Content-Length: 472
  Content-Type: text/xml;charset=UTF-8
  Host: 127.0.0.1:8041

  <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
">
    <soapenv:Header xmlns:wsa="http://www.w3.org/2005/08/addressing">
      <wsa:To>http://localhost:8041/axis2/services/parataMgr</wsa:To>
      <wsa:Action>urn:mmpp:parataMgr/getVersionCheck</wsa:Action>

 <wsa:MessageID>urn:uuid:a6418349-1d84-43d4-801f-98333d974be4</wsa:MessageID>
    </soapenv:Header>
    <soapenv:Body>
      <n:getVersionCheck xmlns:n="urn:mmpp:parataMgr"></n:getVersionCheck>
    </soapenv:Body>
  </soapenv:Envelope>

///////////////////////////////////

  HTTP/1.1 500 Internal Server Error
  Date: Sat, 12 Dec 2009 16:02:42 GMT
  Server: Apache/2.2.11 (Win32) Axis2C/1.6.0 PHP/5.2.5
  Content-Length: 425
  Connection: close
  Content-Type: text/xml

  <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
">
    <soapenv:Body>
      <soapenv:Fault>
        <faultcode>soapenv:Server</faultcode>
        <faultstring>Service Not Found</faultstring>
        <detail>
          <Exception>Service Not Found, Endpoint referance address is
http://localhost:8041/axis2/services/parataMgr and wsa actions is
urn:mmpp:parataMgr/getVersionCheck</Exception>
        </detail>
      </soapenv:Fault>
    </soapenv:Body>
  </soapenv:Envelope>

########## *************** END *************** ##########

Here is the TCPMon log for the .Net WCF client to Axis2/C service that works
just fine

########## *************** BEGIN *************** ##########

  POST /axis2/services/ParataMgr HTTP/1.1
  Content-Type: text/xml; charset=utf-8
  VsDebuggerCausalityData:
uIDPoxSbbbbBUrlHuNPN/pxDwgwAAAAA34KEJ2oVP0O6Dw1Dp8a2Sfbfz3XaB2ZDq08omNFFhx8ACQAA
  SOAPAction: "urn:mmpp:parataMgr/getVersionCheck"
  Host: 127.0.0.1:8041
  Content-Length: 238
  Expect: 100-continue
  Connection: Keep-Alive

  <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/">
    <s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
      <getVersionCheck xmlns="urn:mmpp:parataMgr"/>
    </s:Body>
  </s:Envelope>

///////////////////////////////////

  HTTP/1.1 100 Continue

  HTTP/1.1 200 OK
  Date: Sat, 12 Dec 2009 15:58:09 GMT
  Server: Apache/2.2.11 (Win32) Axis2C/1.6.0 PHP/5.2.5
  Content-Length: 230
  Keep-Alive: timeout=5, max=100
  Connection: Keep-Alive
  Content-Type: text/xml

  <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/
">
    <soapenv:Body>
      <n:getVersionCheckResponse xmlns:n="urn:mmpp:parataMgr">
        <version>100</version>
      </n:getVersionCheckResponse>
    </soapenv:Body>
  </soapenv:Envelope>

Mime
View raw message