axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nagy Vilmos" <nvil...@gmail.com>
Subject Re: Axis2/C application scope problem
Date Fri, 16 Oct 2009 16:06:57 GMT
Hi Shankar,

Thanks for your help.
You are right, the apache is running with prefork mpm and I can't modify it.
My service uses a shared library that performs several operations during its 
initialization.
That's why I would like to use the application scope, but if it is not 
possible, I try to solve my problem with shared memory.

Regards,
William


----- Original Message ----- 
From: "Selvaratnam Uthaiyashankar" <uthaiyashankar@gmail.com>
To: "Apache AXIS C User List" <axis-c-user@ws.apache.org>
Sent: Friday, October 16, 2009 5:27 AM
Subject: Re: Axis2/C application scope problem


> Hi,
>
> When you are running apache httpd in prefork mpm model, there will be
> multiple httpd processes and each will instantiate the service. Can
> you run simple axis server and see whether the service is instantiated
> multiple times?
>
> Regards,
> Shankar
>
> On Thu, Oct 15, 2009 at 6:54 AM, Nagy Vilmos <nvili77@gmail.com> wrote:
>> Dear all,
>>
>> I wrote a service with Axis2/C 1.6.0 and it works fine.
>> The only problem is that I would like to deploy my service in an 
>> application
>> scope.
>> I specified an application scope in the services.xml file, but it has no
>> effect.
>> The Apache Axis2 web service creates more than one instance of my 
>> service.
>>
>> Do I miss something or the application scope is not implemented in 
>> Axis2/C?
>>
>> Thanks,
>> William
>
>
>
> -- 
> S.Uthaiyashankar
> Software Architect
> WSO2 Inc.
> http://wso2.com/ - "The Open Source SOA Company" 


Mime
View raw message