axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jay Sullivan <not...@gmail.com>
Subject Re: Rampart/C Fails to build on Ubuntu 9.04
Date Fri, 28 Aug 2009 18:51:19 GMT
Thank you Sanjaya!  It's really good to see that someone else is able to
reproduce this.  Since I couldn't find this issue in Rampart/C's JIRA
archive, I was thinking I might be doing something wrong. After looking into
the problem more deeply, I'm seeing this issue occur on other platforms; not
just Ubuntu 9.04.  So, it's definitely something that needs to be looked
at.  I've now reported this as an issue:
https://issues.apache.org/jira/browse/RAMPARTC-136.

By running ./autogen.sh first, I was able to fix this issue.  I was able to
run the sec_echo sample and it worked!  However, I should point out that I
am getting *new* errors that seem trivial.  See
http://petio.org/2009/08/28/status.html for details.  But I'm just happy I
have the thing working!

P.S. Since I've joined this mailing list just yesterday, I'd like to make my
intentions clear to everyone.  I'd like to point out that I've tried very
hard to make sure I'm following the official instructions given at
http://ws.apache.org/rampart/c/docs/installationguide.html and I'm pretty
sure I'm not skipping any steps; but it just doesn't work when I follow the
instructions.  This is a sign that the Rampart/C team might want to do some
cleanup on their documentation; both on-site and in the README and INSTALL
files.  If possible, I would be interested in joining the Rampart/C
development team as a documentation janitor.  I've seen a lot of typos that
could easily be fixed.

P.P.S. Personally, I plan to use Rampart/C for a long time to come, and I am
hoping to be able to install it to several platforms.  So, I have a strong
desire to help make sure issues like this can be fixed, or worked around.  I
am also a C developer, so I might be able to contribute more than just
documentation.  My personal website is located at http://petio.org/, where
more information about my skills and interests may be found.



On Fri, Aug 28, 2009 at 3:08 AM, Sanjaya Ratnaweera <sanjaya@wso2.com>wrote:

> Hi Jay,
>
>     I got the same error when I try to compile following exactly same steps
> as yours. But it worked when I compile rampart running build.sh instead of
> ./configure; make; make install. The only deference is build.sh runs
> ./autogen.sh before the configure script. For time being first build rampart
> running build.sh and compile samples after that. Anyway I think this is a
> bug in the pack.
>
> Thanks
>
>     ~sanjaya
>
>
> On Fri, Aug 28, 2009 at 12:39 AM, Jay Sullivan <notfed@gmail.com> wrote:
>
>> Hi.  I am trying to install Axis/C 1.6.0 and Rampart/C 1.3.0 together on a
>> i386/Linux Ubuntu-9.04 system.
>>
>> I can build and install Rampart/C, but the samples will not work. The
>> first sign that there is a problem is when I try to build the
>> "client/sec_echo" sample.  I've written a verbose explanation of how to
>> reproduce the problem: see http://petio.org/2009/08/27/status.html for
>> the details.
>>
>> This is a *major* issue for me, since it prevents me from using Rampart/C
>> at all.
>>
>
>
>
> --
> Sanjaya Ratnaweera
> Senior Software Engineer; WSO2 Inc.
>
> http://www.wso2.com/ - "The Open Source SOA Company"
>

Mime
View raw message