axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vivian Wang <vivianwan...@yahoo.com>
Subject Re: have to remove patented algorithms (IDEA, MDC2 and RC5) in OpenSSL, will this affect SSL and ws-security?
Date Thu, 16 Jul 2009 23:43:38 GMT
Yes, I did some debugging, but this seems to be a bug in axis2/c library. Or maybe I need to
do something like call some APIs so that the status will be set and so users can get the
status?

My question is this, does a user need to specifically do something in order for get_http_status_code
to work? if yes, what needs to be done? 

There doesn't seem to any info in the documentation.

Thanks!
Vivian 




________________________________
From: Rajika Kumarasiri <rajika.kumarasiri@gmail.com>
To: Apache AXIS C Developers List <axis-c-dev@ws.apache.org>
Sent: Wednesday, July 15, 2009 7:37:50 PM
Subject: Re: how to get the http status code
May be some debugging will help?

> Rajika

>On Thu, Jul 16, 2009 at 5:45 AM, Vivian Wang <vivianwangym@yahoo.com> wrote:

>>
>> Hi There,
>>
>> I am using axis2/c to make web service client call, like this:
>>
>>       axiom_node_t * node =
>> axis2_svc_client_send_receive(_wsf_service_client, _env, payload);
>>
>> After this, I am trying to use the following API to get the http status
>> code,
>>
>>       AXIS2_EXTERN int AXIS2_CALL
>> axis2_svc_client_get_http_status_code(axis2_svc_client_t * svc_client, const
>> axutil_env_t * env);
>>
>> I am expecting 408 for time out, 200 for success. However, I am always
>> getting 0. How do I get the proper status code?
>>
>> Thanks!
>> Vivian
>>
>>
>>



      
Mime
View raw message