axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Baier <thomas.ba...@gmx.net>
Subject Re: invalid XML in request for Calculator service
Date Fri, 24 Jul 2009 08:55:21 GMT
Thomas Baier schrieb:
> I've followed the installation instructions and have successfully
> started axis2_http_server.
> 
> Trying to access the Calculator service's WSDL works fine (e.g. from
> Visual Studio 2008) via
> http://localhost:9090/axis2/services/Calculator?wsdl, but any call to
> the service's add method returns "invalid XML in request" as well as the
> same text is shown in the console window where axis2_http_server is running.
> 
> I've also tried soapUI. The request shown is:
> 
> <soapenv:Envelope
> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:typ="http://ws.apache.org/axis2/services/Calculator/types">
>    <soapenv:Header/>
>    <soapenv:Body>
>       <typ:add>
>          <param_1>1.0</param_1>
>          <param_2>1.0</param_2>
>       </typ:add>
>    </soapenv:Body>
> </soapenv:Envelope>
> 
> The response is
> 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>    <soapenv:Body>
>       <soapenv:Fault>
>          <faultcode>soapenv:Sender</faultcode>
>          <faultstring>Invalid XML format in request</faultstring>
>       </soapenv:Fault>
>    </soapenv:Body>
> </soapenv:Envelope>

Just in case anyone is interested in a solution: The WSDL and the sample
source code simply do not correspond. I created my own module based on
the WSDL using WSDL2C and did an implementation and after fixing one of
the include files (wrong format strings for serializer on Windows with
Visual C++ 6.0 and most probably also GCC), my new service worked fine.

Thomas


Mime
View raw message