axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manjula Peiris <manj...@wso2.com>
Subject RE: changing the axis2/c message encoding
Date Sat, 25 Jul 2009 05:03:03 GMT
On Thu, 2009-07-23 at 17:35 -0500, Haszlakiewicz, Eric wrote:
> >>>-----Original Message-----
> >>>From: Haszlakiewicz, Eric [mailto:EHASZLA@transunion.com] 
> >>>
> >>>I want to change the character encoding that axis2/c uses to send
> >>>messages to ISO-8859-1.  I am using adb generated code to send and
> >>>receive the requests.  I figured there'd probably be something 
> >>>I can set
> >>>either in the axis2_stub_t service object, or maybe in 
> >>axis2_options_t,
> >>>but I can't find anything that looks appropriate.  
> >>>How do I do this?
> ...snip...
> >The axis2_engine_send function seems to invokes "phases", so 
> >maybe I can
> >hack something in here to set the charset in the msg_ctx?  I found some
> >general documentation about how phases and flows work in axis2, but I'm
> >not quite sure how to go about implementing a phase.  Can someone point
> >me towards an example?  Does this even sound like a reasonable way to
> >get the encoding set?  It seems like it's way harder than it should be.
> 
> well, to response to my own email yet again, I used the addressing
> module from the axis2c sources as an example and managed to create my
> own module that sets the encoding in the msg_ctx and actually sends a
> request with "Content-Type: text/xml;charset=ISO-8851-1" in the headers.
> Unfortunately, the server side still had a problem deserializing the
> request.  I guess this isn't something that has been tested much, and
> I'm probably in for a world of pain to get it working. :(

Did you engage your module in the server sdie ? What are the errors it
sends ?


> 
> eric


Mime
View raw message