axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <sam...@wso2.com>
Subject Re: RE : RE : Missing data when going through proxy server
Date Thu, 07 May 2009 16:30:52 GMT
It looks like that this is a bug. Please file a Jira and attach the test
code.
Samisa...

On Wed, May 6, 2009 at 11:23 PM, Lefrancois, Carl <
Carl.Lefrancois@axa-canada.com> wrote:

> You're welcome.  I wish I could help more.
>
> Guththila is the parser that serialises the message received from the
> server.  It is already taking what you see in TCPMon directly as input so
> there is nothing more you can do to feed the server response directly.
>
> If everything is fine in your server reply in SoapUI, Paros, TCPMon then it
> is another problem and Manjula and the others are your best bet.
>
>
>
>
>
> -----Message d'origine-----
> De : Eric Hsiung [mailto:erich@bodymedia.com]
> Envoyé : lundi, mai 4, 2009 14:43
> À : Apache AXIS C User List
> Objet : RE: RE : Missing data when going through proxy server
>
>
> Hi, Carl. Thanks for the quick response.
> I've used SoapUI and Paros, both of which show the response that comes back
> from the server, and everything looks fine. I just tried tcpmon and it shows
> the same thing.
>
> I'm not familiar with Guththila but is there some way I can feed the server
> response directly to Guththila and see what happens?
>
> Thanks for your help.
>
>
> Eric
>
> -----Original Message-----
> From: Lefrancois, Carl [mailto:Carl.Lefrancois@axa-canada.com]
> Sent: Monday, May 04, 2009 2:00 PM
> To: Apache AXIS C User List
> Subject: RE : Missing data when going through proxy server [heur]
> Importance: Low
>
>
> Hi Eric.
>
> A few suggestions: check what the client receives with TCPMon.  If you are
> using Guththila, the deserialisation could be stopping when a non-ASCII
> character is reached.  (possibly the proxy software does a
> conversion?)
>
> HTH
>
>
> -----Message d'origine-----
> De : Eric Hsiung [mailto:erich@bodymedia.com]
> Envoyé : lundi, mai 4, 2009 12:53
> À : axis-c-user@ws.apache.org
> Objet : Missing data when going through proxy server
>
>
> Hello, everybody.
> I have a problem that I've been grappling with for days without any
> significant progress, hoping someone can help.
> I have a client using the stub code generated by Axis2/C 1.5. It is talking
> to a Java web services server that has stub code generated by Axis2 1.4.1.
> Thanks for any assistance.
>
>
> Eric
>   _____
>
> "Ce message est confidentiel, à l'usage exclusif du destinataire ci-dessus
> et son contenu ne représente en aucun cas un engagement de la part de AXA,
> sauf en cas de stipulation expresse et par écrit de la part de AXA. Toute
> publication, utilisation ou diffusion, même partielle, doit être autorisée
> préalablement. Si vous n'êtes pas destinataire de ce message, merci d'en
> avertir immédiatement l'expéditeur."
>
> "This e-mail message is confidential, for the exclusive use of the
> addressee and its contents shall not constitute a commitment by AXA, except
> as otherwise specifically provided in writing by AXA. Any unauthorized
> disclosure, use or dissemination, either whole or partial, is prohibited. If
> you are not the intended recipient of the message, please notify the sender
> immediately."
>



-- 
Samisa Abeysinghe
Director, Engineering - WSO2 Inc.

http://www.wso2.com/ - "The Open Source SOA Company"

Mime
View raw message