axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Hsiung <er...@bodymedia.com>
Subject Missing data when going through proxy server
Date Mon, 04 May 2009 16:53:24 GMT
Hello, everybody.

I have a problem that I've been grappling with for days without any
significant progress, hoping someone can help.

I have a client using the stub code generated by Axis2/C 1.5. It is
talking to a Java web services server that has stub code generated by
Axis2 1.4.1.

Some the the web service requests generate large responses, maybe a
string with 130K characters. When the client talks directly to the
server, then everything works fine. But when the client talks to the
server through a proxy server then the response comes back incomplete.
The Axis2/C stub returns a response but some of the fields are null
(like the big string field).

I found this https://issues.apache.org/jira/browse/AXIS2C-936 and I can
deal with it by checking for NULLs in the response, but the question is
why is the response incomplete?

I've tried this with Squid and Privoxy as the proxy servers and both
exhibit the same behavior. I've used tools like SoapUI and Paros to see
the response coming back through the proxy server and they are fine (the
big text string is present). So why doesn't my client app see it? I
don't think it is length related since I've tested with shorter response
strings (a few hundred characters) and the problem still happens.

I also implemented a test program using gSOAP and it worked fine through
the proxy server. 

Has anybody seen this problem with proxy servers before? Any suggestions
as to what might be wrong?
Thanks for any assistance.


Eric





Mime
View raw message