axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Baier <thomas.ba...@gmx.net>
Subject invalid XML in request for Calculator service
Date Sat, 16 May 2009 05:43:13 GMT
Dear List,

I'm completely new to axis2c and I've just downloaded and unpacked
axis2c 1.6 for Windows (binary release).

I've followed the installation instructions and have successfully
started axis2_http_server.

Trying to access the Calculator service's WSDL works fine (e.g. from
Visual Studio 2008) via
http://localhost:9090/axis2/services/Calculator?wsdl, but any call to
the service's add method returns "invalid XML in request" as well as the
same text is shown in the console window where axis2_http_server is running.

I've also tried soapUI. The request shown is:

<soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:typ="http://ws.apache.org/axis2/services/Calculator/types">
   <soapenv:Header/>
   <soapenv:Body>
      <typ:add>
         <param_1>1.0</param_1>
         <param_2>1.0</param_2>
      </typ:add>
   </soapenv:Body>
</soapenv:Envelope>

The response is

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
   <soapenv:Body>
      <soapenv:Fault>
         <faultcode>soapenv:Sender</faultcode>
         <faultstring>Invalid XML format in request</faultstring>
      </soapenv:Fault>
   </soapenv:Body>
</soapenv:Envelope>

The problem is issued in in calc.c (function axis2_calc_add()), where

    seq_node = axiom_node_get_first_child(complex_node, env);

returns NULL.

I've also tried axis2c 1.5, but the problem is still the same.

As I'm sure the Calculator example works fine, I must be doing something
wrong, but I cannot find out.

Browsing the axis-c-user mailing list I have found a similar posting but
no solution.

I would be happy for some hints on how to solve the problem.

Thomas

Mime
View raw message